Cannot Upload Code to nano

hello!
im a arduino uno user. But now i bought a new arduino nano.While uploading the code it shows this error- 2 UNKNOWN: exit status 1
please reply any solutions ASAP

Why ASAP? We are volunteers so we take it as it comes; your problems are not ours.

Anyway, your post is lacking details.

  1. Original or clone Arduino?
  2. What does you operating system think about the board?
  3. Which operating system?
  4. If the board is recognised by your OS, have you tried the different options in the IDE under tools → processor?
  5. If your board is not correctly recognised, you might have to install a driver.
  6. If you still have problems, in the IDE under tools → preferences, disable verbose output during compilation and enable verbose output during upload. Upload the sketch and post the complete result here; there is a button “copy errormessage” to make it easy for you to copy.

There might be something more

That usually indicates that the compiler can’t compile the code, not that upload isn’t working - upload isn’t even starting.

On the IDE, drag the divider at the bottom up to see what other messages are being shown.

here is the information to your questions -
1.its a clone
2.IDK
3.arduino ide software, of course
4.nope i should try
5.how to do it ???
6.ok here is it -
Arduino: 1.8.13 (Windows 10), Board: “Arduino Nano, ATmega328P”

collect2.exe: fatal error: cannot find ‘ld’

compilation terminated.

exit status 1

Error compiling for board Arduino Nano.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

this is what you are asking ?

This old chestnut again.
There should be a second chip on the Nano that does the USB to serial stuff.
Clones often have it on the underside.
Read what the chip is.
If it says FTDI FT232RL, unlikely, it’s good to go.
If it says CH340, it’s the cheepo version.
Having said that, I do use them, successfully.
Look up on this forum “Nano clone will not upload”
And as others have said, don’t say ASAP
Absolutely guaranteed you go go to the back of the queue.
You bought a cheap Nano, expect to get some problems.

1 Like

yeah it shows CH340
does that mean it does not work?
well the site i brought it from is one the most trusted site in my country ?

Looks like a corrupt install to me. And it’s not an upload error !!

i cannot understand what youre saying…

well please tell me how to install the driver to it ?

Who knows if it works, but the CH340 chip has caused a lot of problems.
Do some searching on this forum, because I know that the solution to at least one of the problems has been published.
Again, as said before by others, a lot of people put a lot of free time into this so you need to try as well.
Provided there aren’t any other issues with the board, the CH340 chipped Nanos do work.
I’ll tell you what I think are trusted sites. Genuine Arduino resellers like Digikey, RS, Farnell.
My clones are by Elegoo, complete with CH340 and they all work.
If your trusted site is super cheap, sells unbranded copies, then you take your chances.

@tigger, this problem has nothing to do with the USB driver.

Whatever it’s down to, if he/she had bought a proper board in the first place, they wouldn’t be here.
I’ve never had to install a driver and I don’t think I mentioned driver.
All I know is they often don’t work, but do if you look around in the IDE menus.
If that’s not the solution, I’ll be interested to see what the outcome is.

The problem will even show without a board connected. So it has nothing to do with the board (at this stage).

@iniyan

Could you also review General guidance and how to use the forum as it will help you find your way around.

It covers some of the basic issues including the CH340 drivers.

Doesn’t help if you have an ld error :wink:

1 Like

@iniyan hasn’t posted the code that the compiler complains about with "exit status 1 " yet?

well i used more than 3 codes in youtube and says this same message

Hello!!!
I finally fixed this issue easily…
what I did is first I added a driver to it.
next while I am trying upload it never uploaded.
so after various try and searcher I found my solution which is to select the old bootloader in the tool sections…
I thought it wont come, cuz my nano is new so that it would have a new bootloader but it seems it has a old bootloader.
so once I selected it it uploaded.
thank for all your support and help.
thanks. XD

If old bootloader worked it was mostly likely because you had a CLONE.

Usually a picture of both sides of the board or a link to where you got it would have gotten a quicker response.
Just something to remember in future.

Bob.

1 Like

Glad you got it working.

1 Like