Cannot upload to Nano Every

Hello just bought a Nano Every to test something. Connecting to my (ubuntu) system was no problem, Led-13 was blinking on startup! why?

Wrote a little program (tagged nano as target system) to see some responses in serial-port and tried to upload!!
Compilation was all right but loading did not work
a series of 10 of the following was issued

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

Restarted, changes USB-port and serial monitor give a blank screen, can see my USB-port on system level as active

no improvement, do I need to upload in a different way?
PS
I was using Arduino Uno so far without any problems with this set-up.

Please post all of the error message

install the Arduino-megaavr boards support package and then select Nano Every

Popped up much later ! with a restart it worked! thanks ( my first none-UNU board! )

if it happens again, there is a board with old boot loader as a selection, try that.

That is only relevant for the classic ATmega328P-based Arduino Nano board. HansFu is using a Nano Every, which has no "Old Bootloader" custom board option.

better to say it has no bootloader at all

Oh! I assumed nano every meant every version of nano. Oh well.

These Nano Every boards do seem to be flakey.
I got 2 of them last year and had no problem uploading my own blink test sketch.
It does a few extra things, including sending to the serial port to show activity besides the LED.

Today I went to use one and Windows wouldn't see it. I finally got it working by messing with COMM ports.

However, besides the ignorable warning (jtagmkII_initialize()) (which I just ignore), what I notice is that the 2 data activities lights don't flash.

But the big problem is, if I disconnect it for a while (even a few seconds) and plug it back into the computer, it is no longer recognized and no COMM port is created.

I have to mess around with comm ports and sometimes plugging in the OTHER "VERY" card to get it to work.

THESE CARDS ARE NOT STABLE.

I use regular Nanos, UNO and Mega256 R3 without any problems at all. NONE!