can't compile and upload to my UNO, getting busy signal

hello, my name is Fritz and I am new to coding and adruino.
I am taking a online course (you Tube)from PaulMcWorther and all worked well till this morning.
This morning, I tried to upload a sketch onto my UNO and it hangs up. The message is "BUSY"
I checked on the debug screen and the print out is below.

I am not to good in computer stuff, so any help is apriciated.

thank you
Fritz Peyerl
Alberta Canada

{"Version" : "1.1.251"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "Mary-PC"}
{"OS" : "windows"}
{ "Ports": [ { "Name": "COM4", "SerialNumber": "95730333737351B01100", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.251", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0043" } ], "Network": false }
{ "Ports": [], "Network": true }

I am having the same problem as Fritz on the Web Editor on a Mac with OS 10.15.4 and on window 10.

  • The editor connects to the genuine Arduino Mega and shows a healthy connection (no "x")
  • The same Busy is shown with anArduino Uno as well.
  • It completes the save and the compile phase, but stays on "Busy" (multiple tries >10 minutes.
    -I have been using the Web Editor on the Mac successfully for maybe a month until today.

Mac Debug:

{"Version" : "1.1.251"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "Ervins-MacBook-Pro.local"}
{"OS" : "darwin"}
{ "Ports": [], "Network": true }

Windows 10 Debug:

{"Version" : "1.1.251"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "LAPTOP-F654K4V0"}
{"OS" : "windows"}

I uninstalled Adruino and reinstalled, still same problem.
I removed USB and installed again. Still same problem.
When starting create adruino and coding, it shows that USB4 is active.
When uploading and Busy sign is on, the green light, LED pin13 is glowing and TX LED is glowing.
I have no other windows computer, to test if it is my Laptop.


There were some posts at the top of this section.
They may provide you with some things to try first.

Adding as much detail as you can also increases your chances of a an answer.

Also raised this upstairs. :wink:

Please take a few moments to Learn and Use The Forum

How to get the best out of this forum Installation & Troubleshooting

Hello, Welcome to the Arduino Forum. This guide explains how to get the best out of this forum. Please read and follow the instructions below. Being new here you might think this is having rules for the sake of rules, but that is not the case. If you don’t follow the guidelines all that happens is there is a long exchange of posts while we try to get you to tell us what we need in order to help you, which is frustrating for you and frustrating for us. The people who try to help with your pro…

It will help you get the very best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using. Antivirus etc.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks sterretje )
  • Add your sketch where applicable but please use CODE TAGS
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can


  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.


  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent


  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.

I received a notice this morning that (It appeared and disappeared before I could capture it.) there was a "server issue" and "compiling was , something like, suspended or unavailable.

I tried it later and it compiled and uploaded successfully.

I greatly appreciate the huge effort made by Arduino and all to maintain such a useful system.

All the best,



Thanks for the update.

Sorry you had some issues.