Can't flash Arduino Robot with a new Sketch

Hey,

I've got today the Arduino Robot, but after flashing with the "LEGO"-Sample I can't load an other Sketch on the Robot. Before this, I had an other Sketch on the Board... but now... Can anyone help me here?

Greetings, Allegra

Provide more detail.
Have you tried a different USB cable and USB port?
Are you sure you have the right Board and Port selected?

What error do you get?
What are the RX and TX lights doing while you attempt an upload?

Hey,

USB cable should work, a can programm the motor board with it, so the Port should be the right, too. I have selected the Arduino Contol Board for programming, else I would get an error message. Rx/Tx are blinking while uploading, but after programming there is only the old sketch. Could something strange setting a lock bit?

I'm studing computer science, but there I having no idea.

Thanks for helping me.

So you are not getting any error messages? It is saying Upload Complete?

Are you sure you are uploading the right sketch?

Have you tried any other sketches, like some of the Robot_Control examples?

Yes, I'm getting no error messages, the Upload seems be complete and I had try to load a few examples from Robot Control to the Bot.

Don't understanding what is going wrong.

Probably time to turn on verbose upload logging. Copy all the resulting messages from the sketch window and paste them into a reply here.

Hey,
so I’ve got an error while uploading I havn’t seen before.
Adding the output as attach.
I hope it help you.

CompilingResult.txt (9.67 KB)

UploadResult.txt (14.8 KB)

Connecting to programmer: .avrdude: Send: . [1b] avrdude: Send: S [53] avrdude: ser_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding

Yes, that is definitely an error. That should have been shown even without the verbose setting.

Do you have anything beyond the Robot Motor board connected to your Robot Control board?

No, there is just the pure Robot.

It's beginning to seem like your board is bad. Next thing to try is to upload a fresh bootloader to see if that helps. Might be a good time to order a USBasp ($4) or USBtinyisp ($5) from eBay.

Hey,

after having contact to the support, my problem is solved. Had exactly the problem which were described here: http://forum.arduino.cc/index.php?topic=218511.msg1789544#msg1789544

Thank you very much for your help.

Regards, Allegra

OK, so the auto-reset wasn't working. I wonder if that is a problem with the capacitor connecting the DTR signal to the Reset pin.

I've just reseted the bot once by hand. Now it seems to be working normaly.