Can't Setup MKR WiFi 1010 On Arduino IoT Cloud

Hello,

I’ve got quite a lot of experience with Arduino and electronics in general, although this is my first time working with a WiFi enabled Arduino board. I have setup and used a number of of network related projects on other platforms.

I’ve got the Opla IoT Kit which comes with the MKR WiFi 1010 board.

I’ve managed to work through the tutorials and create my own code in the IDE to connect to my network, access information on the internet and display it on the device without any significant problems - I had to update the firmware on the board before it would connect to my network.

I’m now trying to get the board set up through the Arduino IoT Cloud. I’m following the steps to setup a new device, with the MKR board plugged in, the plugin running, select Arduino device, it detects the MKR WiFi 1010 board and allows me to continue to configure and name the device. It then runs through 3 steps, uploading the sketch (which it completes and I can hear the relay on the IoT carrier tick over), it completes the second step and then keeps failing on the 3rd, being some sort of final check.

I get this error each time:

{“id”:“3Z8W7MfK”,“code”:“bad_request”,“status”:400,“detail”:"[RM54Su0+] 400 invalid_request: request.wifi_fw_version must match the regexp “^(?P0|[1-9]\\d*)\\.(?P0|[1-9]\\d*)\\.(?P0|[1-9]\\d*)(?:-(?P(?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-])(?:\\.(?:0|[1-9]\\d|\\d*[a-zA-Z-][0-9a-zA-Z-]))))?(?:\\+(?P[0-9a-zA-Z-]+(?:\\.[0-9a-zA-Z-]+)))?$" but got value “”, attribute: request.wifi_fw_version, value: , regexp: ^(?P0|[1-9]\d)\.(?P0|[1-9]\d*)\.(?P0|[1-9]\d*)(?:-(?P(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-])(?:\.(?:0|[1-9]\d|\d*[a-zA-Z-][0-9a-zA-Z-]))))?(?:\+(?P[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$”}

I’ve tried this on a Mac on Chrome and Safari and on a Windows 10 PC on Chrome and Firefox. I’ve also tried on two Networks, and my phone’s hotspot network.

I’m not really sure how to go from here. You can’t edit or see any of the code being uploaded to the device by the Arduino IoT Cloud application, so I’m not sure where/why it is failing and the error doesn’t look like it has any useful troubleshooting information.

The board is also “upset” by this process and goes into a mode which can only be recovered with a double tap of the reset button otherwise it’s unrecognised by the computer and application.

@mklementsdiy , I can't say for sure that this is a solution, but I had a very similar problem, and after attempting this I finally had success with configuration.
The error I was getting (also at the 3rd step), was "Cannot set property 'long string' of undefined". My device was also being corrupted by this process, causing my Win10 machine to report that "USB device not recognized". I had to use the double-tap reset method and another PC to recover as you did. I checked the list of whitelisted apps in my firewall to make sure the plugin was included. I could see that arduino_create_bridge was already included. I added the other two applications which are in the plugin folder to my whitelist:
Arduino_Create_Bridge_cli
certmgr

Not sure if they are both necessary to whitelist, but I included them both. After adding those and attempting configuration in IoT Cloud again, it finally succeeded. I hope you have similar results.

I am having the same problem with two different MKR 1010's that will not add to the IOT Cloud, I get the error "Can't update Firmware: 'loaderPath' is empty or 'null' "
I can upload sketches via the IDE on both 1010's so I'm not sure if its the browser or the plugin, or both for the cloud.

Any help would be appreciated.

Cheers.

1 Like

Not sure if it may help but here's to things to try, if it's still an issue for you.

  1. You can update the firmware using the offline IDE. follow the directions here: https://forum.arduino.cc/index.php?topic=579306.0

  2. I reoccurring problem for me is that after a reset (there are multiple resets required in the IOT setup). The MKR 1010 will not stablish a port connection after the first reset. 1) Start Device Manager -- > Expand (Ports & LPT) --> When all is good you should see your Arduino board named, or at least one of those will only be there when the Arduino is connected 2) Start the process in Arduino IoT. 3) When the first reset of the Arduino happens; you'll know because the port will disappear in Device manager, unplug and re-plug the board, the Port should show up and the process should continue.

To connect your MKR Wifi 1010 as a Device in the Arduino IoT Cloud (https://create.arduino.cc/iot/devices) you need firmware version 1.4.1. This can only be updated using the installed Arduino IDE and a USB-cable to the device. However, the default installation from https://www.arduino.cc/en/software is version 1.8.13, and is only able to update firmware to 1.3.1 So go to https://www.arduino.cc/en/software#hourly-builds and download the last Hourly Build version. You get a zip file, unpack it, and just run arduino.exe. This get's you (at this moment) IDE 1.8.14 Hourly Build 2021/01/27 07:33. Connect your board with USB, and follow https://www.arduino.cc/en/Tutorial/WiFiNINA-FirmwareUpdater to update the firmware. Now the process to add your Device to the IoT Cloud will work in one go.

I can get MKR WiFi 1010 to log onto my network, I get the address: 10.0.0.4, but when I try to connect I get "Cannot connect to server" Since the code, upload, etc. all seem to be working fine, not sure where to look next?
Any suggestions?

Hello there, do you still have this issue? If yes please provide:

  • Operating System (and version)
  • Arduino Create Agent version
  • Browser and version

Thanks!

I am having a similar issue, but the error I am getting is:

Start command: exec: "{runtime.tools.fwupdater.path}/FirmwareUploader": file does not exist

I am new to Arduino so any help is appreciated!

I resolved my issue by updating the firmware as ejhogenbirk suggested above. A few things that tripped me up initially were having install a different package that included my board (mkr wifi 1010), and having to upload "serialNINAPassthrough" before uploading the "Firmwareupdater" when following the https://www.arduino.cc/en/Tutorial/WiFiNINA-FirmwareUpdater guide.

I have the same problem -- get stuck in step 3 trying to add a WiFi1010 board. Updating the firmware to 1.4.1 did not change anything. Step 3 never completes, then it just jumps back to Add a Device - no error messages at all.

OS is Windows 10, Browser is Edge, have no idea who to find out version of Create Plugin.

1 Like

Hello,

we just deployed an update on Arduino IoT Cloud to fix the issue:

Start command: exec: "{runtime.tools.fwupdater.path}/FirmwareUploader": file does not exist[color=#222222][/color]

Can you please try again now?

I am currently struggling with my new “Explore IoT Kit”, trying to set up my “MKR WiFi 1010” as an IoT Cloud device.
Going through the steps in the Activity 2 tutorial, I am able to select the proper board, through the correct COM and going through all 3 configuration steps. So far, so good.
The tutorial says “If nothing goes wrong, we will see a screen telling us it was successful. Simply press the Done button to finish the configuration.”
But in my case I do NOT get the “Done” message, but the program asks me to set up a new device. And so on, and so on …
Please advise.

I followed the suggestion of ejhogenbirk (Jan 29, 2021).
And I was able to upgrade my "MKR WiFi 1010" firmware from version 1.2.3 to 1.4.3 (sic).
Then I was able to set up the "MKR WiFi 1010" to the IoT Cloud.
Thanks.

Had a similar issue going through Iot Explorer kit Activity 2, specifically with trying to update the firmware of the board for IoT cloud function. updating it from the offline IDE and waiting a bit after the updater starts and errored out, fixed it for me.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.