Caricamento arduino

Salve a tutti non mi carica più nessun programma in arduino (uso l 'ATMEGA2560)
come posso risolvere? devo comprare una scheda nuova? tra l altro appena la collego al pc neanche fa il rumore di quando viene collegata

@matteo41996: non avendolo tu ancora fatto, nonostante te lo abbia già chiesto, ti invito cortesemente a presentarti QUI (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) ed a leggere con attenzione il REGOLAMENTO ... Grazie.

Guglielmo

Faccio! ma come risolvo?

Se apri le "risorse di Windows", tra le porte seriali, non ti mostra nulla? Hai fatto qualche cosa (che ti ricordi) prima che smettesse di vederla? Hai qualche cosa collegato ai pin 0 e 1?

Guglielmo

Nel caso peggiore ... provare a riprogrammare il ATmega16U2 ...
... trovi i dettagli nel reference della Mega, capitolo "Programming" ... ::slight_smile:

Guglielmo

gpb01:
Se apri le "risorse di Windows", tra le porte seriali, non ti mostra nulla? Hai fatto qualche cosa (che ti ricordi) prima che smettesse di vederla? Hai qualche cosa collegato ai pin 0 e 1?

Guglielmo

per risorse di windows intendi gestione dei dispositivi? se si non mi vede niente
comunque non ho niente collegato a nessun pin
ieri sera funzionava stamattina l'ho lasciata collegata ad un alimentatore da 12v e si è scaldata molto....
non vorrei sia per quello però bruciata non è perchè alimentazione gli arriva...

Se non c'è nulla collegato ... non si deve scaldare molto ... considera che 45/60° che a te sembrano scottare ... per un componente sono una temperatura di lavoro accettabile. Se invece mi dici che stava a 80/90° e più ... allora c'è qualche cosa che assorbe più del dovuto ... ::slight_smile:

Comunque se non la vedi da PC, se cambiando il cavo USB non cambia nulla e se scalda sempre parecchio anche senza nulla collegato ... direi che c'è un guasto.

Guglielmo

nono collegata ad un pc non scalda forse era l alimentatore
il problema è questo
se collego arduino uno me lo riconosce sulla com 4 ma non mi fa caricare lo sketch ugualmente
mentre
se colleco arduino mega 2560 non me lo riconosce :S

Versione di Windows e versione dell'IDE ?

Guglielmo

P.S.: Considera che per ulteriori aiuti probabilmente dovrai aspettare qualcuno che è su Win ... io vado a memoria perché sono su OS X :wink:

windows 10
ide 1.6.9
Non so come proprio come fare!

L'ultima versione STABILE è la 1.6.8 ... la 1.6.9 è una "hourly builds" ... con i problemi che può introdurre una versione in sviluppo ... ::slight_smile:

Guglielmo

quando carico uno sketch su arduino uno mi da questo errore:

Arduino:1.6.7 (Windows 10), Scheda:"Arduino/Genuino Uno"

Opzioni di compilazione cambiate, ricompilo tutto

Lo sketch usa 1.030 byte (3%) dello spazio disponibile per i programmi. Il massimo è 32.256 byte.
Le variabili globali usano 9 byte (0%) di memoria dinamica, lasciando altri 2.039 byte liberi per le variabili locali. Il massimo è 2.048 byte.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xce
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xce
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xce
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xce
avrdude: ser_recv(): read error: Operazione di I/O terminata a causa dell'uscita dal thread oppure della richiesta di un'applicazione.


Problema di caricamento sulla scheda. Guarda http://www.arduino.cc/en/Guide/Troubleshooting#upload per suggerimenti

  Questo report potrebbe essere più ricco di informazioni con
  "Mostra un output dettagliato durante la compilazione"
  abilitato in "File > Impostazioni"
[\code]

Nessuno che lo sappia fare???

... l'errore indica che NON riesce a parlare con il bootloader ... hai già provato a cambiare il cavo USB?

Guglielmo

si

Come si resetta il bootloader?

matteo41996:
Come si resetta il bootloader?

? ? ? :o :o :o Che intendi ?

Il bootloader parte da solo ed è in una zona protetta della memoria flash ... e sono sicuro che NON è un problema di bootloader ... al limite un problema del ATmega16U2 (quello che interfaccia la USB), ma molto più probabilmente qualche cosa sul PC.

Guglielmo

prova a tenere il monitor seriale aperto.
oppure premi reset prima che parta un nuovo tentativo, riesci a farlo un paio di volte durante l'invio

Allora se tengo il monitor seriale aperto mi da questo errore

Arduino:1.6.9 Hourly Build 2016/04/28 04:33 (Windows 10), Scheda:"Arduino/Genuino Uno"

Lo sketch usa 1.066 byte (3%) dello spazio disponibile per i programmi. Il massimo è 32.256 byte.
Le variabili globali usano 9 byte (0%) di memoria dinamica, lasciando altri 2.039 byte liberi per le variabili locali. Il massimo è 2.048 byte.
avrdude: ser_open(): can't open device "\\.\COM4": Accesso negato.


Problema di caricamento sulla scheda. Guarda http://www.arduino.cc/en/Guide/Troubleshooting#upload per suggerimenti
Exception in thread "Thread-70" java.util.ConcurrentModificationException
	at java.util.LinkedList$LLSpliterator.forEachRemaining(LinkedList.java:1239)
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
	at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)
	at cc.arduino.contributions.libraries.LibrariesIndexer.rescanLibraries(LibrariesIndexer.java:123)
	at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:835)
	at processing.app.Base.onBoardOrPortChange(Base.java:1245)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2439)
	at java.lang.Thread.run(Thread.java:745)

Questo report potrebbe essere più ricco di informazioni con l'opzione
"Mostra un output dettagliato durante la compilazione"
abilitata in File -> Impostazioni

se invece premo reset non succede niente, si blocca su " STO CARICANDO...."

ciao, prima di tutto scaricati una versione stabile di IDE (come diceva Guglielmo la 1.6.8 ).

come seconda cosa, quell errore probabilmente significa che qualche altro programma sta usando la seriale. prova a chiudere tali programmi, e prima cambia versione di IDE, che magari è un bug della beta.