Controler une LED avec Blink

Bonjour,

J'essaye de contrôler une LED avec Blink en suivant ce tutorial :
http://osoyoo.com/2018/02/05/osoyoo-yun-iot-led-blink/

Du coté du logiciel Arduino 1.8.10, lorsque je clique sur Moniteur série j'obtiens le message d'erreur suivant :

"Connexion impossible : le croquis utilise-t-il le pont?"

Du coté de l'appli Blink de mon smartphone, j'ai le message

"Not connected yet"

Je pense etre plus tres loin de finaliser mon tout 1er projet, je vous remercie pour votre aide !

Bonjour

Du coté du logiciel Arduino 1.8.10, lorsque je clique sur Moniteur série j'obtiens le message d'erreur suivant :

"Connexion impossible : le croquis utilise-t-il le pont?"

le moniteur série est-il réglé sur la bonne vitesse (bauds) ?

Yun est ses variantes sont très peu utilisées par les participants de ce forum (beaucoup moins que les Raspberry Pi, ESP8266 ou ESP32 !!!!) Le choix de ce kit utilisant un shield Yun va restreindre ; d'autant plus que le fortement les possibilités d'aide.... d'autant plus que le shield en question n'est pas celui d'Arduino mais celui, concurrent, de Dragino.

Pour avoir de l'aide à partir du message d'erreur rencontré , Cliquer sur la Loupe en haut à droire sur ce forum et Recopier le message d'erreur : Connexion impossible : le croquis utilise-t-il le pont.
Des échanges à son sujet arriveront.

Merci pour ces infos !
Je ne sais pas si le moniteur série est réglé sur la bonne vitesse, mais il est indiqué 300 bauds.
Est ce la bonne vitesse ? Si non, comment la modifier ?
Merci.

la 'bonne vitesse' est celle fixée quelquepart dans le code envoyé dans la carte Mega2560
La doc du kit devrait l'indiquer !!

Dans le doute il n'ya pas de risque à tester d'autres vitesses en cliquant en bas de l'écran du terminal
(9600 bauds et 115200 bauds sont les vitesses les plus fréquentes dans les exemples)
vitesse.png

vitesse.png

Merci !
Dans la doc il est indiqué clock speed 16 MhZ. J'ai essayé différentes vitesses dans le moniteur serie, mais j'ai l'impression que ces modifs ne sont pas prises en compte car lorsque je réouvre le moniteur serie, il m'indique la valeur par defaut de 300 baud...

16 MHz est la vitesse de calcul du processeur, la valeur en baud est différente, c'est la vitesse de communication sur le port.

Le problème peut aussi provenir d'un smartphone qui n'a pas encore accepté la demande d'appariement sans fil.

Merci pour cette info.
J'ai trouvé 115200 baud dans la doc comme vitesse max pour la Mega2560.

Christian_R:
16 MHz est la vitesse de calcul du processeur, la valeur en baud est différente, c'est la vitesse de communication sur le port.

Le problème peut aussi provenir d'un smartphone qui n'a pas encore accepté la demande d'appariement sans fil.

Comment puis je le vérifier ?

Bonsoir,

J'ai essayé différentes choses, tout désinstaller, recommencer maintes fois, mais j'ai toujours les mêmes problèmes :

  1. Sur blink "Wasn't online yet" et

  2. Sur le moniteur serie "Connection impossible" et "le croquis utilise t-il le pont ?"

Quelqu'un a t-il une idée de tests que je pourrai faire pour me sortir de ce casse tete ?
Merci d'avance !

Bonsoir

pour le second message utiliser un moteur de recherche pour le message d'erreur (propre à Yun)
"le croquis utilise t-il le pont" (il me semble que le "pont" désigne la connection entre le processeur AVR et le processeur Atheros sous Linux)

ça donnera peut être des pistes.....

Bonsoir,

Merci pour la réponse. J'ai deja utilisé le moteur de recherche mais sans succès pour l'instant, raison pour laquelle j'essaye de trouver de l'aide ici :slight_smile:

oui mais içi Yun n'a pas fait recette ...... ni la première ... délaissée par Arduino, ni la seconde version tardive, ni les shields Yun variés..

difficile donc de faire des suggestions sur cette histoire de 'pont'.....

par contre quelques utilisateurs de Blynk sur ce forum

le créateur du kit a-t-il un forum ? propose-t-il un support ?
Voir aussi chez Dragino (créateur du shield utilisé : Wiki, Google Groups....)

Quelle est la version du shield Yun Dragino ? (pour certaines versions il faut faire une petite modif sur la carte Mega2560 pour éliminer le conflit sur le port série entre la liaison Arduino-ShieldYun et le retour d'infos vers le PC...
....le message d'erreur est peut être le symptôme du conflit ??

Voir içi la partie sur la Mega2560 : http://wiki.dragino.com/index.php?title=Yun_Shield
confit RxTx.jpg

confit RxTx.jpg

Bonjour,

otrsa:
Osoyoo Yun IoT Lesson 9 – Control a LED Blink(Blynk) « osoyoo.com

Sur le sketch fourni le serial n’est pas prévu :

#define BLYNK_PRINT Console
#include <Bridge.h>
#include <Console.h>
#include <BlynkSimpleYun.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "Your Auth Token";
void setup()
{
  Blynk.begin(auth);
  // Debug console
  Bridge.begin();
  Console.begin();
  while (!Console);{}
  // You can also specify server:
  //Blynk.begin(auth, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, IPAddress(192,168,1,100), 8442);
}
void loop()
{
Blynk.run();
// You can inject your own code or combine it with other sketches.
// Check other examples on how to communicate with Blynk. Remember
// to avoid delay() function!
}

Et où se trouve le serveur ?

@+

Bonjour otrsa,

otrsa:
Bonsoir,

Merci pour la réponse. J'ai deja utilisé le moteur de recherche mais sans succès pour l'instant, raison pour laquelle j'essaye de trouver de l'aide ici :slight_smile:

Avez-vous essayé google avec :
yun "Unable to connect: is the sketch using the bridge?"

Cordialement,
bidouilleelec

Merci pour vos réponses !

@al1fch:

Bonne idée, je vais contacter le createur du kit, si j'obtiens la solution je la posterai ici.
La version du shield est V.1.1.6 donc nul besoin de modif sur la carte.

@J4l13n:

J4l13n:
Sur le sketch fourni le serial n'est pas prévu :

En effet, car je me connecte en wifi...A moins qu'il y a quelque chose qui m'echappe, ce qui est bien possible car je suis debutant !

J4l13n:
Et où se trouve le serveur ?

J'ai ajouté cette ligne au code :
Blynk.begin(auth, IPAddress(192,168,1,100), 8442)
en spécifiant bien auth et l'adresse IP, mais j'ai toujours le meme probleme.

A noter quand meme que la compil se passe bien et le téléversement aussi. (Petite précision la LED s'allume, mais je parviens pas à l'allumer / eteindre via blynk)

Merci encore !

Rajouter le serial pour debugger.

@+

J4l13n:
Rajouter le serial pour debugger.

@+

Heu...c'est à dire ? Un programme de deboggage qu'il faut que je telecharge ou est ce autre chose ?

Non

juste démarré le serial de communication entre le pc et la carte :

avec un :

Serial.begin(9600); // ou plus...

@+

Pas certain que ça fonctionne comme ça dans la famille Yun !
Serial() ne semble pas utilisable car 'réquisitionné 'pour le "pont" entre le processeur AVR et la puce linux

Il semble que le debug passse par Console, (telnet sur WiFi)

Ah.. il n'y a pas de console serial sur les Yun ... ok..

J'ai essayé

Serial.begin(9600);

mais cela ne change rien en effet.

Je ne sais pas si cela peut aider mais lorsque je vais dans outils/récupérer les informations de la carte j'obtiens le message suivant : "Port réseau, impossible de récupérer les informations"