Coupure alimentation Arduino

Bonjour à toutes et tous,

Alors voilà, je débute avec l’arduino et je me suis fait un petit robot pour suivre la lumière. C’est assez simple et j’ai découvert pas mal de choses. Le schéma est attaché (la carte est alimentée par la prise Jack mais je débute aussi sur Fritzing )

Je pense avoir un problème d’alimentation. En effet, ma carte ne fait que redémarrer. Je l’ai constaté en allumant une diode pendant le setup.

J’ai donc testé les cas suivants pour essayer de comprendre :

  • Alimenter l’arduino via le 5V du module moteur L298n et non le jack : même problème
  • Alimenter l’arduino via l’usb du pc et non le jack : tout fonctionne nickel, les moteurs tournent
  • Alimenter l’arduino par le jack selon le schéma mais débrancher in1 in2 in3 in4 : la carte fonctionne normalement mais évidemment les roues ne tournent pas...

Je suppose donc que j’ai trop de puissance sur la batterie mais d’un autre côté je suis surpris parce que parfois tout fonctionne correctement pendant quelques secondes...

La seule solution que j’ai est de rajouter une pile 9v pour alimenter l’arduino séparément des moteurs, mais avoir deux sources d’alimentation je trouve ça merdique et je suis convaincu que je passe à côté de quelque chose...du moins je voudrais comprendre!

Si quelqu’un peut éclairer ma lanterne ce serait top!

Merci

Voici la pj : Dropbox - Schéma voiture suiveuse lumière_bb.jpg - Simplify your life

Le forum ne m’a pas laissé télécharger l’image elle même

Bonjour catsur

1/

Je suppose donc que j’ai trop de puissance sur la batterie

Ou plutôt pas assez?
Vous ne précisez pas la puissance consommée par le moteur

2/

Je pense avoir un problème d’alimentation.

Quel type d'alimentation utilisez vous ?
[/quote]

3/

  • Alimenter l’arduino via le 5V du module moteur L298n et non le jack : même problème

Vous ne précisez pas où vous connectez ce 5V sur l'arduino

4/

La seule solution que j’ai est de rajouter une pile 9v pour alimenter l’arduino séparément des moteurs, mais avoir deux sources d’alimentation je trouve ça merdique

C'est pourtant la meilleure, voire la seule solution possible : parasites , puissance....

Cordialement,
bidouilleelec

  • 1 avec Bidouilleelec

Ce que tu décris correspond tout à fait à une mise en sécurité automatique du régulateur de la carte arduino quand on lui fait débiter trop de courant.
Il chauffe → il se met en sécurité, plus de courant → il refroidi → quand il est suffisament refroidi la tension se rétablie : l’arduino redémarre et le courant passe dans les moteurs → il chauffe → etc

Donnes plus de précision sur les moteurs et sur l’alimentation.

Bonjour catsur

Ton problème, à la base, provient du fait que ton alimentation n'a que 6v. (4x1.5).
Or un régulateur, autant sur l'Arduino que sur la carte H298, pour fournir du 5V. nécessite au minimum 7V.

La solution est d'alimenter la carte L298 ainsi que l'Arduino, sur son jack ou sur Vin en 9V.
Ou alimenter la carte L298 et l'Arduino sur sa pin 5V: avec le 5v. de la L298.

Cordialement
jpbbricole

Bonjour,

Merci à tous pour vos réponses rapides!

Pour répondre aux questions :

bidouilleelec:
Bonjour catsur

1/Ou plutôt pas assez?
Vous ne précisez pas la puissance consommée par le moteur

Oui c'est ce que je voulais dire. La puissance consommée je ne la connais pas; mais ce sont les petits moteurs jaunes d'un kit robot 2WD achetés 3 francs six sous sur le net;

bidouilleelec:
2/Quel type d'alimentation utilisez vous ?

J'utilise 4 piles 1,5V soit 6V en tout et effectivement jpbbricole a mis la main sur le problème je pense....

bidouilleelec:
3/Vous ne précisez pas où vous connectez ce 5V sur l'arduino

Sur le Vin

bidouilleelec:
C'est pourtant la meilleure, voire la seule solution possible : parasites , puissance....

Je vais voir pour faire comme ça alors, c'est vrai que j'ai pas fait attention à ça, j'ai pris le kit et zou...

Merci à vous mais également à jpbbricole! Communauté très réactive!

Je regarde ça dans la semaine, j'ai déjà commandé de quoi brancher une pile 9V!

Bonjour 68tjs

68tjs:

  • 1 avec Bidouilleelec

J’aurais préféré un karma! ;D

Cordialement frustré,
bidouilleelec

Le volà :grin: