Dead/empty ftdi (mprog guilty?)

I was checking mprog utility from ftdi with my decimila connected. "Scan for available devices" showed that they are 0 empty devices and 1 programmed on my system. I played a bit after pressing "Read and parse" changing the vendor, etc, then I have pressed "Cycle device" button and my decimila stop working. I haven't upload anything!

Now everytime when I connect the decimila, windows says "unknown device" and with usb viewer I see: "'0x00" for all that of that device with "DeviceFailedEnumeration" message as device label.

What happened?

Futher more, I can not even reprogram the ftdi chip (Arduino Playground - HomePage) because mprog does not find any device now . :frowning: I have already killed a decimila ftdi connecting by error 10v on some point, but it was fixable with a lot of work (desoldering the ftdi and resoldering it with a regular soldering iron), I don't want to repeat that experience! :-/

thanks

Have you tried running the FTDI FTClean utility, it will remove the drivers to allow the installer to rediscover devices

It also didn't work on other computers, so I am sure that is not the windows drivers :frowning:

If you were messing around with the vendor etc, windows might not know what to do with it. I used MPROG to reprogram some of the chips but I left the vendor alone and just re-assigned the device ID so instead of that annoying 'A7006' serial number they show up as just one (makes programming a bunch of them about 100 times easier).

I'd say check the device manager and see if there are any unrecognized devices. Try to point it to the FTDI driver if you can.

thanks, but I have pointed to the ftdi driver (default, and others from ftdi website) :frowning: none of them have worked

:frowning:

any other guess?

How will be detected the arduino with an empty ftdi?

Anyone knows? As a normal arduino? I mean usb serial converter? something like that?

I played a bit after pressing "Read and parse" changing the vendor, etc,

Looks like it's possible you reassigned the vendor and device codes. Like Sterling suggested, look for any unrecognized USB devices on your system. See if MPROG will find it using the vendor ID on the unrecognized device.

-j

Thanks kg4wsv, but when I connect Arduino USBView show this:

Device Descriptor:
bcdUSB:             0x0000
bDeviceClass:         0x00
bDeviceSubClass:      0x00
bDeviceProtocol:      0x00
bMaxPacketSize0:      0x00 (0)
idVendor:           0x0000
idProduct:          0x0000
bcdDevice:          0x0000
iManufacturer:        0x00
iProduct:             0x00
iSerialNumber:        0x00
bNumConfigurations:   0x00

ConnectionStatus: DeviceFailedEnumeration
Current Config Value: 0x00
Device Bus Speed:     Low
Device Address:       0x00
Open Pipes:              0

So I can't assign any other driver, I have tried to update the "unknown device" driver with usb to serial converter driver from ftdi, but I just get:

"This device cannot start. (Code 10)".

:-[

Maybe there is a way to manually clear the ftdi eeprom?

Try and use this info (specifically the vendor ID and product ID) to see if you can make mprog a) talk to the device, and b) program the correct vendor and product IDs (0403 and 6001, I think).

-j

Was this every solved?

I have a Nano V3 (new in box) that gives the same data with USBView as reported by TS. I would love to hear if and how it has been solved?

Edit: I need to add that mprog/ft_prog doesn't find the device.

I replaced the ftdi chip ... :slight_smile: problem solved