Elegoo UNO R3 Issues

I'm currently running into massive issues when trying to turn my Elegoo UNO R3 into a MDS (MAC Deployment Stick), the program I'm running compiles okay but when i try and upload it i get the error below:

avrdude butterfly_recv() programmer is not responding

Until it says Serial port not found or device not connected (something like that)

I've checked in ports and its connected to /dev/cu.usbmodem4211(Arduino/Genuine UNO), ive seen forums stating it needs to be /dev/tty.usbmodem but the drivers is tells me to install doesn't work.

I'm running Mojave 10.14.4 which the latest Arduino build. I've also tried on High Sierra and OS Yosemite to no avail. Can anyone help with this issue

Are you following a tutorial? If so, please post a link to it.

https://twocanoes.com/knowledge-base/how-to-set-up-arduino-ide-for-mds-automaton/

That is the link to the tutorial I am following, when I select my board in tools I now get the error stated in the below picture.

55f00d0495ca5e1cd4e338b114a285efadc1680f_2_828x1000

Doesn't seem the picture is uploading but the error is:

"HID Project can only used with an USB MCU" Erro compling for board Arduino/Genuino Uno.

The tutorial is written for a board that uses the ATmega32U4 microcontroller. The ATmega32U4 has native USB capabilities. Your Uno uses the ATmega328P microcontroller. The ATmega328P does not have native USB capabilities, and thus is not suitable for this project*.

I recommend you to buy an ATmega32U4 based board.

This error:

Jack1995: avrdude butterfly_recv() programmer is not responding

Happened because you tried to upload to your Uno with the wrong board selected from the Tools > Board menu. To upload to your Uno, you need to select Tools > Board > Arduino/Genuino Uno.

  • Full disclosure, the Elegoo Uno does have an ATmega16U2, which is used as the USB to TTL serial adapter chip. That microcontroller does have native USB functionality. It is possible to program the ATmega16U2, but this is an advanced process.

Thanks for the reply, how advanced would it be to make it work? and I've recently just brought that from the link below will the program I'm trying to run now work with this

https://shop.pimoroni.com/products/adafruit-itsybitsy-32u4-5v-16mhz?gclid=CjwKCAjwndvlBRANEiwABrR32BccHwU6EfcIp0728TCYKKilQV8nLa59NG7GY___o0XNHi-rTcVHNRoCZgAQAvD_BwE&utm_campaign=google+shopping&utm_medium=cpc&utm_source=google&variant=2982346063882

Jack1995: how advanced would it be to make it work?

Take a look at the readme and wiki page of this repository: https://github.com/NicoHood/HoodLoader2 that documents the whole procedure.

Jack1995: https://shop.pimoroni.com/products/adafruit-itsybitsy-32u4-5v-16mhz?gclid=CjwKCAjwndvlBRANEiwABrR32BccHwU6EfcIp0728TCYKKilQV8nLa59NG7GY___o0XNHi-rTcVHNRoCZgAQAvD_BwE&utm_campaign=google+shopping&utm_medium=cpc&utm_source=google&variant=2982346063882

Yep, that's what the author of the tutorial is using. You could also use an Arduino Leonardo, Arduino Micro, or a Pro Micro, which all use the same ATmega32U4 microcontroller.