Error compiling[Win7-64bit, Arduino Uno R3 -00023

Hi all: I just bought an Arduino Uno R3 yesterday at Radio Shack. I think I have done everthing I can think of to make it work, but it won't. The control panel under ports states Arduino Uno R3(COM17), the port settings are : Bits per second: 9600 Data Bits: 8 Parity: none Stop bits: 1 Flow control: none

When I plug in the board, I get the plugin sound; when I unplug the board, I get the unplug sound. When I try to upload the Blink program, I get the error message- Error compiling. I have tried to upload this blank program:

void setup() { }

void loop() { } same error. I have reinstalled the program seveal times. I downladed a fresh zipfile copy of Arduino 0023, I have renamed the folder that holds the program files and folder. I notced that the orange LED blinks at about the same rate as my 4GB tumbdrive I use to speed up my system, so I pulled that out, no change. I pulled my wireless mouse doglel out, no change. I have tried the reset on the R3 board, it blinks fast for less than a second, then does the slow blink rate again. When I first pluged in the board, the blue and red TX and RX lit up, but have not done that again when I try to upload a program to the board. From all this, I think I must have a bad setup in my computer. I am running Win.7 (64 bits) on a Acer Aspire 7741Z-4643 notebook. I have gone read all 82 pages of the forum, tried anything that might look like part of the problem. What should I try next?

Can you post the exact error messages you are getting?

The message reads "Error compiling." It comes right after I hit the upload button or the menu "Compile/Verify". Thank you for your time.

From one newbie to another, I'm probably no help, but . . . I also got an Uno R3 from Radio Shack. There were no drivers for it on 0022, but got one from 0023. I'm running Windows XP Pro 32 bit. I can compile just fine. My only curiosities are that the TOOLS menu, the UPLOAD button and the SERIAL MONITOR all take 30 seconds to function. So, except for the 30 second problem, mine appears to be working OK

Thank -you. I may have a bad board. But, I think the program should compile then give a error about the I/O. I guess I will wait a little longer before returning it. Bill

What happens if you set build.verbose to true in your preferences.txt file (you can find its location in the preferences dialog)? You might get a more detailed error. It doesn't sound like it's an issue with the board, but rather the software install. Maybe try downloading and unzipping it again?

Thank-you. I did a new download and install. No change. I then edited the file like you said. I then ran it, same thing. I checked the file, for some reason, the file did not have the command in it. I then edited the file again, close the file reopened the file and the command was still there. I then close the file, reopen the 0023, loaded blink and then tried to upload the program to the board- result no change. I then reopen the file and the command was gone again. I checked the file and the read-only box was not checked. Is the file a cabnet file? Bill

Gave up, took the board back to Radio Shack for a refund. For now I will stick to Parallax's Propeller microcontoller, it works. I may try again with the Arduino in about six months. =(