EVAL232R uno upload issues

i just got a new computer which doesnt have regular serial ports, but i did get a free EVAL232R that out puts TX/RX etc signals in ttl format from USB. so i hooked it up and installed the drivers, but it wont upload anything, of course. TXD of the eval is going to RX on the arduino and RXD is going to TX. previously this arduino was using a MAX232 and the serial cable and worked fine. It is a breadboard duino with the optiboot(UNO) bootloader on a 328p. so then i connected RX and TX of the EVAL together and i got the echo. so im guessing it something to do with serial port settings in device manager; mine are 9600 8N1. i changed it to 115200(the uno upload speed) but no go.

oh, and when it doesnt upload it says 0x00. so it seems like no connection at all. swapping rx/tx doesnt help. neither does manual reset.

what do ya think? sorry to post this, but i have tried all the common causes and i have run out of ideas.

fixed it. apparently i miss read because it gives out the regular RS232 voltages. it has the FT232RL chip to go from USB->TTL levels and then a CMOS chip to convert those ttl levels to regualt RS232 voltages. so i just connected my MAX232 back to it and got ttl levels.

i may find the traces and solder some headers directly from the ttl tx/rx/dtr pins for later use as it would much easier to use.

another issue :wink:

this time im using a USBasp as usb->ttl converter http://ullihome.de/wiki/USBAVRLab/Firmwares/USBasp . yes they are ttl voltages as the DMM says 4.56v when measuring on GND and TXD. it passes the loop back test and i still get 0x00 error (no connection at all) when uploading...

i am using the manual method to reset it on upload but ive done it plenty of time before on another arduino.