HC-05 does't return ok for few commands

I'm trying to connect HC-05 to a device (HC-05 connected with Arduino Uno), I managed to enter the AT command and currently in process of connecting it. here are the pairing command:
` * AT+UART=57600,0,0

  • AT+ROLE=1
  • AT+PSWD="0000"
  • AT+CMODE=0
  • AT+BIND=C464,E3,EB8454
  • AT+IAC=9E8B33
  • AT+CLASS=0
  • AT+INQM=1,9,48`

when I tried to enter AT+PSWD="0000" it doesn't return OK as it should be. then I check it out by AT+PSWD? it returns PSWD:1234 the problem also applies with the address

here's the screenshot of my serial monitor

update:
I managed to add the address AT+BIND=C464,E3,EB8454 but when I checked by AT+BIND? returns +BIND:0:0:0

@ha_chaeyeon, your topic has been moved to a more suitable location on the forum. Installation and Troubleshooting is not for problems with (nor for advise on) your project :wink: See About the Installation & Troubleshooting category.

Although I don't know too much about BleuTooth modules, please post the sketch (and use code tags). Are you using SoftwareSerial (on which pins)? Or hardware serial on pins 0 and 1?

Thank you and sorry:)

No worries. I've modified my original post and asked an additional question.

I use a blank sketch therefore I don't post any sketch. but here's how I connect HC05 with the arduino Uno

Arduino Rx pin to HC05 Rx pin
Arduino Tx pin to HC05 Tx pin
Arduino 5v pin to HC05 Vcc pin
Arduino3.3v pin to HC05 En pin
Arduino GND pin to HC05 GND

I believe that for changing the passwd the 6th pin (EN/KEY) must be also connected to HIGH (3.3 V).

I tried that one and still the same

Some HC05 modules have 2 AT modes. If you hold the button and power it up then release the button it goes into a "mini" AT mode. If you press the button, power the module and keep the button depressed, it will enter "full" AT mode. I use a small alligator clip to hold the button. Or you may, with some modules, use the EN pin or solder a wire to a pin to use to put the HC05 into AT mode. Do be aware that even though the module is powered by 5V the pins are not 5V tolerant.

See here for more information.

I tried to depressed all the time the button it doesn't work. Should I bought a new one?

Are you sure that it is a HC05? Post photos of the module, front and back.

How are you communicating with the module? What baud rate?

yes, I'm highly sure it is HC-05 (I'll upload the module here). I used it once but I believe it's broken due to intensive usage. I follow this tutorial How to Pair HC-05 Bluetooth Modules - YouTube at baud rate 38400

Here goes another guess:
Some modules use to come with Baud Rate of 9600 as a default. If your module is 38400 or you have changed before to 38400, ok, but if you didn´t, it´s a good bet setting up serial monitor to 9600 as a test.

I solved the problem by upgrade it to VERSION:4.0-20190815 from VERSION:4.0-20190728

1 Like