Help, please!

I was working with my Arduino UNO today, when all of a sudden I couldn't upload instructions to it anymore. Whenever I do, the Arduino shows that it recieves a burst of electricity--which then dies, since the ON light switches on and fades. We tried using a battery connection and it worked fine, but we couldn't edit the code at all. Eventually the electronic parts started frying! We even tried switching USB cables and rechecking the wiring, but the UNO still won't connect at all. Whenever we try to upload through the cable, the same message pops up:

avrdude: stk500_getsync(): not in sync: resp=0x00

What's going on? Do I need to buy a new UNO? Halp! :fearful:

Looks like you broak it. What were you doing? I hope it was not wiring up while it was still powered, that is a favrout way. What got hot? Mainly it is the USB chip that gets fried and that is almost impossible to replace without a hot air soldering station.

Eventually the electronic parts started frying! ... What's going on?

You tell us. The computer doesn't start "frying" on its own. Perhaps a wiring diagram or photo would help.