Help! The Lights are on but nobody's home!

Hi All

Board = Arduino UNO OS = Mac OSX (Lion)

I'm new to this. I bought an Arduino and got it to do what I wanted! Switches controlling outputs etc! Then I managed to blow a board up by being careless with some relays and a 12volt supply! Fried the regulator on the board! Oops!

Anyway - bought a new one! Developed my nobel prize winning code and all was great! :-) Last night everything fine! Go to upload today and it won't work... I get the message:

avrdude: stk500_recv(): programmer is not responding

It compiles fine! But won't upload! I've tried the loopback test and that does nothing :-( The USB ports work on my mac and I've tested the USB cable and in-fact tried a different cable! No good either!

The lights are on! Power and pin 13 flashes but nothing happens...

I've tried pressing reset at strategic times before uploading but... you've guessed it - nothing!

Anyone any thoughts - or have I somehow (without touching it - clever) broken another one!?

Thanks

Jimmy

did it work after you changed regulator? try to meassure voltage that is on board when it's connected

The regulator went on my old board. (which I will try and fix) I'm not sure what's happend to this new one...

The problem is that your new board does not have auto reset. "Programmer not responding" happens when you don't hold the reset button long enough or in your case, at all. When uploading your code, hold the reset button for 2-3 secs RIGHT when it says "compiling". Be patient if you don't get it the first time, it not easy.

IF dtr isn't supported... It could be that your ftdi cable's headers aren't seated correctly on the arduino's headers