Homeing Settings

Hi Everyone,
I have just installed micro switches on all 3 axis, and enabled $21=1 all works well. I have done the same to $20 to allow homing....when i press the homing button the Z axis moves to the limit switch and stops, It does not move on to the X or Y axis?

Any help would be greatfully appreciated

I assume that this question is related to CNC so have moved the topic here. Much more details of your system and the problem are required

Ok, I am using an openbuild blackbox on my 1mt x 1mt CNC, I have wired 2 micro switches on each axis as per grbl with "NO" as the function. The only alterations to the grbl setting that I have made are, setting $21 to 1 and looking at the grbl info it says set $20 also to 1 other than these changes the setteings remain as they came out the box.
So, what happens is that the Z axis moves up hits the switch and then stops with the alarm on.

Again any help would be appreciated. Cheers.

What is the alarm?

Try increasing "homing pull off", $27.

Hi, and once again thanks for the advise. It did the trick however, perhaps you can help with another issue that I have.
I am now getting a warning coming up which says: error 15- jog target exceeds machine travel. Command ignored [ $J=G91G21Y10F1200]
I have attached below a copy of my machine settings, perhaps you would be kind enough to look through them and advise where I have gone wrong.

[12:29:45] [ $$ ] $0=10 ;Step pulse time, microseconds

[12:29:45] [ $$ ] $1=255 ;Step idle delay, milliseconds

[12:29:45] [ $$ ] $2=0 ;Step pulse invert, mask

[12:29:45] [ $$ ] $3=0 ;Step direction invert, mask

[12:29:45] [ $$ ] $4=1 ;Invert step enable pin, boolean

[12:29:45] [ $$ ] $5=0 ;Invert limit pins, boolean

[12:29:45] [ $$ ] $6=0 ;Invert probe pin, boolean

[12:29:45] [ $$ ] $10=115 ;Status report options, mask

[12:29:45] [ $$ ] $11=0.010 ;Junction deviation, millimeters

[12:29:45] [ $$ ] $12=0.002 ;Arc tolerance, millimeters

[12:29:45] [ $$ ] $13=0 ;Report in inches, boolean

[12:29:45] [ $$ ] $20=1 ;Soft limits enable, boolean

[12:29:45] [ $$ ] $21=1 ;Hard limits enable, boolean

[12:29:45] [ $$ ] $22=1 ;Homing cycle enable, boolean

[12:29:45] [ $$ ] $23=3 ;Homing direction invert, mask

[12:29:45] [ $$ ] $24=60.000 ;Homing locate feed rate, mm/min

[12:29:45] [ $$ ] $25=800.000 ;Homing search seek rate, mm/min

[12:29:45] [ $$ ] $26=250 ;Homing switch debounce delay, milliseconds

[12:29:45] [ $$ ] $27=3.000 ;Homing switch pull-off distance, millimeters

[12:29:45] [ $$ ] $30=1 ;Maximum spindle speed, RPM

[12:29:45] [ $$ ] $31=0 ;Minimum spindle speed, RPM

[12:29:45] [ $$ ] $32=0 ;Laser-mode enable, boolean

[12:29:45] [ $$ ] $100=320.000 ;X-axis steps per millimeter

[12:29:45] [ $$ ] $101=320.000 ;Y-axis steps per millimeter

[12:29:45] [ $$ ] $102=188.976 ;Z-axis steps per millimeter

[12:29:45] [ $$ ] $110=1500.000 ;X-axis maximum rate, mm/min

[12:29:45] [ $$ ] $111=1500.000 ;Y-axis maximum rate, mm/min

[12:29:45] [ $$ ] $112=500.000 ;Z-axis maximum rate, mm/min

[12:29:45] [ $$ ] $120=10.000 ;X-axis acceleration, mm/sec^2

[12:29:45] [ $$ ] $121=10.000 ;Y-axis acceleration, mm/sec^2

[12:29:45] [ $$ ] $122=10.000 ;Z-axis acceleration, mm/sec^2

[12:29:45] [ $$ ] $130=500.000 ;X-axis maximum travel, millimeters

[12:29:45] [ $$ ] $131=500.000 ;Y-axis maximum travel, millimeters

[12:29:45] [ $$ ] $132=200.000 ;Z-axis maximum travel, millimeters

Kind regards,
John.