IDE's Tools/Port does not show my Nano

I'm trying to use my first Arduino, a Nano. I'm using the latest IDE (v 1.8.16) on my Windows 10 PC.

When I connect the Nano, it seems to be running "Blink" - fine.

Setting up the Nano for the IDE, I set board = Nano, processor = 328P - fine.
But I can't set port. The option is greyed out.

But when I modify Blink, reducing one of the 1000mS delays to 500mS, and try to upload it, the IDE sometimes reports it is unable to upload the sketch, which I put down to the IDE not seeing the Nano. Fair enough, but why is it not seeing it?

I tried setting the processor to "Old bootloader" and "168" - no change.

As suggested, I tried to update the driver. But when I go to Windows Device Manager, the Nano isn't there, so there is no way to change the driver.

I wonder whether Windows is seeing the device at all. But when I unplug and replug it into its cable, Windows gives the usual 4-tone signal, indicating it has seen a new USB device.

The Arduino doco seems to have little to say about Windows 10. So I feel somewhat in the dark.

Any ideas?

PS I have done microcontroller development on PIC devices, no problem.

  • Geoff

That's because there really is nothing to say. Windows creates a virtual COM port using the installed driver and the Arduino uses it

What shows up in Windows Device Manager when you plug the Nano in ? You may need to run Device Manager in Administrator mode and enable "dhow hidden deviced"

Additional information. Sometimes the upload seems to work, and gives no error message, it just says something like "compilation completed" - but the old Blink code is still running in the Nano, with both delays at 1000mS. Other times, it reports failure, saying "Serial port not selected".

Hi, thank you for the suggestion.
I tried "Show hidden devices" in Device Manager, and two new ones appeared under Ports (COM & LPT): they were called "USB Serial Device (COM3)" and "USB Serial Device (COM4)" .
When I double-click on these entries in the list, both show device status of:
Currently, this hardware device is not connected to the computer. (Code 45)
To fix this problem, reconnect this hardware device to the computer.

  • Neither seems to be the Nano.

You say

So what turns up in Device Manager when you connect the Nano ?

Thanks UKHeliBob,
In a word - nothing. I can find no entry for the Nano, and I've searched all the categories of device, not just "Ports (COM & LPT)" and "Other devices".

Also, I've tried two different USB ports on the PC, and two different USB cables. The Nano seems to use the "Mini" USB device-end connector.

I'm now wondering whether both my cables are charge-only types...

  • Is there an easy way to tell?
  • Would Windows give its 4-tone happy noise with a charge-only cable?

If the cables were charge-only then you would not get the Windows tones when you connected the Nano

Try deleting these with the Nano disconnected and connecting it again. Do either of the reappear ?

When I highlight say the COM3 device in Device Manager, and hit the delete key, it warns me that I'm about to uninstall this device from my system. Will it be easy, later, to reinstall it?

I don't know, so remove it at your own risk

If it were me then I would go ahead and remove it but you choose

Hmmm... I've always been a bit mystified by COM ports in Windows... I don't think I'll try it.
My PC is dual-booted with Linux, so I might try the same Nano & cables under Linux.
But thanks for your thoughts on this.

  • Geoff

You are aware that you will not see the word Nano in device manager?

In below image (for demonstration), a genuine Uno with 16U2 is on COM8, a SparkFun RedBoard with a FT232 is on COM5 and a clone Nano with CH340 chip is on COM10. An genuine Nano should show like the SparkFun RedBoard.

The FTDI also shows under Universal Serial Bus Controllers as an USB Serial Converter in device manager; it's where I found an issue a few days ago and it did not show under Ports.

===

Right click on COM3, select properties. If it doesn't tell you what it is in the general tab, go to the details tab and select Hardware Ids. It will give you the VID and PID that you can lookup on the web. Repeat for COM4. You can base your decision to remove on that (or on what Linux tells you in lsusb and dmesg).