ioctl("TIOCMGET"): Inappropriate ioctl for device

Does anyone know what to do?
This happens when I tried to upload blinking led from my macbook pro to Uno v3.0
and yes i´m a beginner!

avrdude: ser_open(): can’t open device “COM1”: No such file or directory
ioctl(“TIOCMGET”): Inappropriate ioctl for device

Ok i just solved it

Can you give us a clue as to how you fixed it? I am having the same issue.

I cannot find any usb modem when I try to select the port. I have only bluetooth showing up.

I don't understand the guys who ask a question... waiting to all the people to help him.

And, just say "Ok i just solved it"... and bye bye !!!!?????

kitesurf77, you can't help the others guys ?

my macbook pro
   :
can't open device "COM1":

On a Mac, the serial port will look like "/dev/cu.usbserial-A20e1KH5" or similar. "COM1" is a windows name for a port. It's probably a bug somewhere that the Mac software is defaulting to a windows port name, but the fix is "don't forget to set the "port" to the correct value."

Try this https://www.youtube.com/watch?v=Sdou3Uib9Hw

it worked here