IRLZ44N schaltet dauerhaft durch

Hallo,

ich versuche mich als Anfänger momentan an einer recht simplen Schaltung, aber irgendetwas klappt nicht.

Mit einem IRLZ44N versuche ich per Arduino einen 12V Motor anzusteuern.

  • Der Motor bekommt + direkt von der Stromquelle. Mit - hängt er an “Drain”.
  • Source geht dann zu - der Stromquelle.
  • Source und Gate sind mit einem 20k Ohm Widerstand verbunden.
  • Gate ist mit dem Arduino verbunden und hat noch einen 150 Ohm Vorwiderstand drin.
  • Der Arduino bekommt ebenfalls 12V und Masse von der gleichen Stromquelle

Leider schaltet der Mosfet sofort durch und auch eine Spannung an Gate ändert nichts am Verhalten.
Im ausgeschalteten Zustand ist der Widerstand zwischen Drain und Gate unendlich.
Die Polung sollte lt. Datenblatt stimmen (Gate - Drain - Source; von links nach rechts).

Poste mal dein Datenblatt und ein Schaltbild, wie du es verdrahtet hast.
Vermutlich hast du den Mosfet falsch angeschlossen.

Der Schaltplan ist als Anhang dabei. Ich habe leider gerade kein besseres Programm hier.

Datenblatt gibts hier: https://www.infineon.com/dgdl/irlz44npbf.pdf?fileId=5546d462533600a40153567217c32725

Hi

Würde Den genau so anschließen - von Vorne betrachtet G-D-S
irlz44n.pdf, Seite 8
irlz44n, Infineon, ebenfalls Seite 8 (Link von elkoso)

Wenn Du noch EInen hast - tausche Die Mal durch - vll. hast Du Dir diesen Einen geschrottet - die Dinger sind etwas empfindlich, was Überspannungen angeht - >20V am Gate und der FET ist gewesen - mit Teppich oder Synthetik auf dem Stuhl kann Das recht schnell passieren.

MfG

Edit
Auch URL-Tags sollte man korrekt zusammen pfriemeln ... oder die Vorschau benutzen grmpfl

postmaster-ino:
Hi

Würde Den genau so anschließen - von Vorne betrachtet G-D-S
.....

Das sehe ich auch so.....auf die Beschriftung gesehen.

elkloso:
Mit einem IRLZ44N versuche ich per Arduino einen 12V Motor anzusteuern.

  • Der Motor bekommt + direkt von der Stromquelle. Mit - hängt er an "Drain".
  • Source geht dann zu - der Stromquelle.
  • Source und Gate sind mit einem 20k Ohm Widerstand verbunden.
  • Gate ist mit dem Arduino verbunden und hat noch einen 150 Ohm Vorwiderstand drin.
  • Der Arduino bekommt ebenfalls 12V und Masse von der gleichen Stromquelle

Leider schaltet der Mosfet sofort durch und auch eine Spannung an Gate ändert nichts am Verhalten.

Ich vermisse bei deiner Aufzählung eine Freilaufdiode.

Einen neuen Mosfet habe ich auch schon probiert. Ich hatte Angst, dass ich sie zu heiß gelötet hatte o.ä.

Finnlay:
Ich vermisse bei deiner Aufzählung eine Freilaufdiode.

Die habe ich erstmal im Testaufbau nicht eingebaut, weil ich dachte, dass die nur davor schützt, dass durch den Motor Spannung induziert wird. Da ich eine geschlossene Pumpe verwende kann eig. niemand am Motor drehen o.ä. wodurch eine Spannung erzeugt wird.

Die Freilaufdiode ist ein Must have, da hat Finnlay schon Recht.
Ohne die, stirbt der Mosfet.
Was wohl auch passiert ist.

Induktionsspannungen entstehen auch beim Ausschalten des Stromflusses. Damit könntest Du den FET schon gekillt haben.

Gruß Tommy

Okay, dann besorg ich mir mal welche. Ich hab leider nur noch Zener-Dioden zuhause, die bringen mir da ja nichts.

Die Dioden sollten für den Nennstrom des Motors ausgelegt sein.

Gruß Tommy

Hi

Nicht desto Trotz kannst Du Deine Schaltung auf Funktion testen - nur sollte die Last, ohne Freilauf-Diode, nicht induktiv sein - z.B. eine LED würde sich anbieten (nebst Vorwiderstand).

Nicht viele Dinge sind in der Elektronik nur wegen dem guten Aussehen verbaut - auch, weil der Kram Geld kostet, wird sich jeder Entwickler darum bemühen, Zeug, Das irgendwie weg kann, auch weg kommt.
Sonst bekommt Der Haue auf die Finger von Seinem Boss - und Das hat der Entwickler dann auch nicht so gerne.

Soll heißen: Wenn überall eine Freilauf-Diode verbaut wird, wird Das wohl einen Grund haben.
Die eigene Entscheidung, Die weg lassen zu können, wird man dann beim Finanz-Minister begründen müssen, wenn doch Was kaputt geht und man neu kaufen muß.
Ähnlich die ganzen Kondensatoren, Die überall bei Elektronik verbaut sind, werden wohl nicht nur als Ausgleichsgewichte dienen.

MfG

Doofe Frage, kann ich als Last nicht einfach ein Multimeter nehmen und schauen, ob 12V durchgeschaltet werden?

Da hast du natürlich Recht mit der Diode. Wie gesagt, ich hatte ihren Zweck nur falsch interpretiert und sie deshalb weggelassen. War halt mein Fehler, aber so lernt man halt auch

elkloso:
Doofe Frage, kann ich als Last nicht einfach ein Multimeter nehmen und schauen, ob 12V durchgeschaltet werden?

Nein. Wenn dann müsstest du den Strom in Reihe messen.

Du kannst einen Widerstand als Last nehmen und daran die Spannung messen

Hi

Ein DMM hat, ähnlich dem sperrendem FET, einen recht hohen Widerstand.
Da ist's wohl besser, wenn Du als Last einen Widerstand nimmst, Der den Strom so klein hält, daß Er selber Das auch überlebt - also irgend etwas aus der Krabbelkiste im KΩ Bereich, da kommen dann nur mA zusammen und die Leistung, Die der Widerstand aushalten muß, bleibt ebenfalls 'im unteren Bereich' (5V x fließender Strom = Verlustleistung).
Auch ist dieser Widerstand dann trotzdem noch um Größenordnungen kleiner, als der sperrende FET oder das DMM.

MfG

Ich habe es jetzt mit einer LED inkl. Vorwiderstand an einem neuen Mosfet versucht.
Die LED leuchtet, egal welcher Zustand Gate hat.
G ist okay, da habe ich je nach High/Low entweder 0V oder 3,3V anliegen.

Kann es denn an der Lötstation liegen, dass die den Mosfet schrottet?
Ich hab zwar damit schon komplette 3D Drucker gebaut und KFZ-Steuergeräte nachgelötet, aber beim Mosfet scheine ich kein Glück zu haben.

elkloso:
Ich habe es jetzt mit einer LED inkl. Vorwiderstand an einem neuen Mosfet versucht.
Die LED leuchtet, egal welcher Zustand Gate hat.
G ist okay, da habe ich je nach High/Low entweder 0V oder 3,3V anliegen.

Kann es denn an der Lötstation liegen, dass die den Mosfet schrottet?
Ich hab zwar damit schon komplette 3D Drucker gebaut und KFZ-Steuergeräte nachgelötet, aber beim Mosfet scheine ich kein Glück zu haben.

Wenn du eine Pumpe an einem Mosfet ohne Freilaufdiode betreibst, überlebt der das nicht.
Die Lötstation ist das vermutlich nicht, die den getötet hat.
Da du Station schreibst, hat die sicher einen Trafo und arbeitet mit niedriger Spannung.

HotSystems:
Wenn du eine Pumpe an einem Mosfet ohne Freilaufdiode betreibst, überlebt der das nicht.
Die Lötstation ist das vermutlich nicht, die den getötet hat.
Da du Station schreibst, hat die sicher einen Trafo und arbeitet mit niedriger Spannung.

Es geht doch darum, dass es gerade bei einem nagelneuen Mosfet und einer LED (statt Motor) auch nicht geht.
Ich dachte eher wg. fehlendem PE vllt.

elkloso:
Es geht doch darum, dass es gerade bei einem nagelneuen Mosfet und einer LED (statt Motor) auch nicht geht.
Ich dachte eher wg. fehlendem PE vllt.

Oh....sorry, das mit dem "neuen" Mosfet hatte ich übersehen.

Hast du einen Widerstand am Gate gegen GND ?

Dann würde ich eher auf Dich als aufgeladenen Körper tippen (Gummisohlen usw.)
Das sehen wir aus der Ferne nicht.

Gruß Tommy