Leonardo Problems bootloader

I had an arduino leonardo , which my friend took , and tried to upload the arduino micro bootloader onn , using his arduino uno , and arduino IDE , using the arduinoISP sketch ! He Got the message " Done burning Bootloader" , then he got arduino micro on com 8 ... then , when he tried to upload the fade sketch , the com port vanished away , arduino micro bootloader com port didnt come ....and IDE was Uploading....!
He gave me my Leonardo With the default Bootloader , but still i have the same problem !
when i connect my leonardo , com 4 appers , i click upload , it goes , then the bootloader com 5 appears , then .........................................................NOTHING HAPPENS !
its just ......that !
i tried flashing the firmware caterina leonardo , leonardo prod firmware , using an ISP i had Lying around, but still No help !

I have tried using an Uno to upload the fade code on the leonardo , and it worked ! , but when i tried to do the same thing using the USB , nothing happens !

sometimes , while experimenting with micro firmware on leonardo , while pressing the upload button , suddenly the Tx and Rx led's got mad , and started blinking , and the board does not respond ! what does that mean ?

Please tell me , what has happened to my board , and how shall i fix it !