Librerie Arduino IDE 2.0.0

Ho installato su un pc con Windows10 il nuovo IDE di Arduino, il 2.0.0.
Mi funziona correttamente ma io vorrei installare tutte le librerie che ho nella versione 1.8.16.
Sul PC non riesco a trovare il percorso dove c'è la directory "Librerie", per fare il passaggio.
Ovviamente non ho le "vecchie" zippate e non posso farlo tramite 'IDE.

Lello

Premesso che la versione 2.0 è una beta, moooolto beta con svariate lacune e bugs, comunque puoi installare tutte le librerie da ... quell'abbozzo di Library Manager che c'è e che le mette al posto giusto.

Per il resto, io lavoro su macOS e quindi non so bene dove Windows sparga (come suo solito) le varie cartelle in giro per il disco ... dovrai aspettare qualcuno che usa quella beta su Win.

Opinione personale ... pessima idea quella di installare la 2.0 Beta ... solo problemi e essenzialmente nessun vantaggio pratico ... la 1.8.16 è l'attuale versione stabile (... e ben funzionate).

Guglielmo

A parte che la 2.0.0 è una "alpha che si crede beta", temo che senza gli zip originali non si possa fare granché...

aspetta la finale. e poi se hai gli arduini clone ..lì non li accetta ansi li accetta ma ogni volta devi selezionare la board e la porta per me una rottura.
Per le librerie guarda su github Arduino Libraries · GitHub perché nella 2-.0 c'è il comando arduino-cli.. ma non chiedermi come funziona.. mai provato e io vado via github.
le librerie le devi mettere nella cartella documenti e nella sotto cartella Arduino\libraries

Tanto ogni volta controlla lì e controlla in c:\program files\arduino\libraries\

etc.

Saluti, tu aspetta la finale .. perché io lo messa zippata ma ha problemi nei arduini clone ovvero la versione mega mi fa difficile ad caricare gli sketch alcune volte va alcune volto no..

e sono ritornato alla 1.8.16 stable.

saluti e buona settimana.

Lo so che è sempre una pessima idea installare le Beta dei programmi.
Ma c'è un problema a monte.
Ho installato ultimamente su Windows 10 la versione di Arduino I.DE 1.8.18.
Quando lo lancio mi da l'immagine dell'ideatrice per 5 0 sei secondi, come se lo stesse caricando e poi sparisce.
Non lo carica.
Allora ho provato con la versione IDE 1.8.16 ma mi da lo stesso risultato.
A qual punto ho installato la 2.0 e per adesso mi funziona regolarmente, ma mi mancano tutte le vecchie librerie che non so in quale directory mettere.
Proverò a disinstallare la 2.0 e riprovo a caricare la 1.8.16 o 18.
Intanto uso l'IDE che ho sul Mac e funziona regolarmente.
Lello

P.S.: non uso cloni Arduino

La 1.8.18 NON è una release ufficiale e non so dove tu l'abbia presa (magari è una hourly build da NON usare). L'ultima versione ufficalmete rialasciata e supportata è la 1.8.16.

Ho idea che sulla tua macchina tu abbia un bel casino (con Windows è facile) e il consiglio è di disinstallare tutto ed installare una versione "portable", che, oltretutto, oltre ad essere sandboxed e anche, come dice il nome portabile semplicemente copiando la cartella, da una macchina all'altra.

Scarica la versione .zip (NON l'eseguibile o peggio quella da Win Store), scompatta lo zip in una cartella dove tu hai tutti i diritti di lettura e scrittura e rendila "portable".

In questo modo avrai tutti i "core" e tutte le librerie racchiuse nell'unica cartella "Arduino" che, volendo, potrai anche rinominare, ad esempio, in Arduino_1_8_16 e, quando esce la 1.8.17, se vuoi, puoi avere tutte e due in linea facendo la stessa cosa e rinominado la nuova Arduino_1_8_17, tanto sono completamente chiuse su se stesse e l'una non vede l'altra.

Guglielmo

a me mai avuto problemi.. forse perché dovete sempre dire che il mac è migliore senza sapere che il mac è unix like ed in più si porta dietro librerie di Linux/Unix oltre ad questo .. prova a vedere se ti mancano le librerie Visual c++ runtime 2015 o 2013 qualcosa del genere .. io le ho tutte installate e i programmi mi si installano senza problemi.. prova vedere anche se è attivo l'utente normale e devi eseguire l'installazione da utente amministratore con il click destro del mouse a me me la fatto con windows 21h2 con l'installazione di python che anche se ero amministratore o dovuto per forza fare esegui come amministratore.

Vedi il controllo utenti .
saluti.

... guarda che non hai capito nulla di ciò che ho scritto!

Io ho sia macchine Win che macOS, le prime le uso per determinate cose le seconde per altre, Arduino è sulle seconde. Che Windows sparga dappertutto i files è un dato di fatto, così come è un dato di fatto che macOS è basasto si Darwin (BSD) ed a me, dimostarre che uno è meglio dell'altro, non può fregare di meno ... lavoro con entrambi.

L'OP ha problemi, io t'ho dato un'indicazione ed un modo pulito per installare l'IDE, poi ciascuno fa come gli pare.

Guglielmo

Grazie Guglielmo,
i tuoi consigli mi sono sempre utili.
Non so come mai mi sono inventato la versione 1.8.18, in pratica non l'ho mai avuta.
Sul Mac ho la 1.8.16. ed è quella che ho provato a installare su Windows10.
Seguirò anche le indicazioni per rendere l'IDE portatile.
Saluti

Lello

1 Like

ha ok, ma se tu hai macchine windows e mac quando ti ci voleva dire all'utente di controllare la cartella del suo utente e nella sotto cartella "documenti" e nella terza cartella "arduino" .
cosi per me stai facendo il figo e non sai nemmeno che in default arduino sia la 2.0 e la 1, mettono la cartella in documenti.
E la 2.0 viene installata senza librerie perché ci possono essere librerie obsolete e che vanno in conflitto ecco perché ho detto che c'è il comando arduino-cli per scaricarle ma io essendo che non lo imparato ad usarlo vado via di github e clono il progetto tramite il pulsante "download" e poi aggiungo lo zip nella cartella libraries .
ciao .. per me quelli che hanno l'apple fanno solamente credere che hanno i soldi .

@gigetto1982 : Visto quanto scrivi e il modo piuttosto arrogante con cui lo scrivi, per ora ti vene data una settimana di sospensione (fino al 17.12.21). Se la cosa si reitererà la sospensione sarà definitiva.

Guglielmo

P.S.: ... tra l'altro, se avessi letto il mio post aversti visto che ...

quindi, ovviamente, NON posso sapere dove sono le cartelle sotto Win dato che Arduino lo uso sotto macOS.

Mi spiace di aver creato queste "incomprensioni", non era nella mia intenzione.
Saluti

Lello

@LelloGi : tanquillo, non sei certo tu ad avere certi atteggiamenti :slight_smile:

Spero piuttosto che con la versione "portable" hai risolto ... è molto utile se vuoi avere differenti installazioni di IDE sia magari di differenti versioni, sia magari con "core" e librerie differenti :wink:

Guglielmo

Una cosa che forse Guglielmo potrebbe confermare, la cartella portable, per quanto lo sporadico test, dovrebbe anche essere "multipiattaforma", quindi copiando da windows a linux o viceversa, ci si ritrova con le stesse "cose" da entrambe le parti.
Devo rifare la prova con l'installazione su linux che ho su un pc secondario.

NI ... ovvero, tutto ciò che riguarda le librerie lo è, ma i "core" contengono spesso anche gli strumenti per la compilazione (le varie cartelle "tools"), che sono degli eseguibili e che, ovviamente, sono diversi piattaforma per piattaforma.

Guglielmo

In effetti...

In settimana, appena rientro a casa, seguo i tuoi consigli della versione "portable".

Lello

Risolto!
Installata su una chiavetta e "Portable" è ripartito e non mi da più problemi.
Grazie dei consigli.

Lello

Ottimo !!!

E ricordati che di "portable" ne puoi fare quante ne vuoi, ciascuna è indipendente, quindi, ad esempio, puoi tenere in linea differenti versioni, separare i "core", ecc. ecc. :wink:

Guglielmo