Macbook Pro can't detect a Mega 2560

I just received a new mega 2560 (see attachment).

I tried to plug it into my Macbook, but the computer can't detect it. (See other attachment).

So I tried to install this : VCP Drivers - FTDI but it didn't solve the problem.

I also tried 2 differents cables, still stuck.

My OS version is 10.10.4

Thanks :slight_smile:

(I hope the card isn't already borken :confused:)

1 Like

Well, you probably can't use FTDI drivers for a non-FTDI USB chip. You need to look at the chip by the USB port and see what the chip is, and download the driver for that chip. Maybe it is a CH340G, I can't just yet hack into your webcam and zoom in on that chip and get a good look at it from here.... :slight_smile:
The web site where you bought the board may have a link to the driver.

Hi, thanks for your answer.

Well, I bought it on Alixpress and they don't say much about the board there. I asked the seller but he takes time to reply. All I can read on board is: ATMEGA2560 - 16AU 1519.

I bought it here :

As I can't see the board in the USB list, I don't know how to get more informations about the board. :confused:

Get out a magnifying glass, or if you've got good eyes just look at the chips on the board itself, and read the numbers. The biggest chip is the ATmega2560, and the second-biggest chip near the USB connector is the USB-to-serial adapter chip, that is the one you need the drivers for. You may need to get into some really good light, perhaps sunlight, and hold the board at just the right angle to read the numbers on some chips.

Thanks again,
Well I can read CH340G 202645801 on it.

So I went here:

But the board is still undetected ...

This forum post
and this article
talk about making an additional nvram setting for Mac, I wonder if that's what you need. I have installed the CH340G driver for my Mac, but I'm afraid it has been a while since I did that and I don't remember exactly what I did.

I tried these to links. I also tried on my PC (running on W8), it can't detect the arduino neither ...
Now, I think that the only solution is to buy a new one ... :frowning: