MacOS Sierra: No Plugin Connection on Chrome and Safari

Hi All,

I'm running Safari Version 10.0.2 (12602.3.12.0.1) and Chrome Version 55.0.2883.95 (64-bit) on MacOS Version 10.12.2 (16C67). I have tried to install the plug-in, but during the installation process I still get the following message in both Chrome and Safari:

We are not able to detect the installed plugin.
Was the installation successful? Try running the Installer again, or ask a question on our forum.
Loading...Looking for installed plugin...

Also, in the Web Editor I get the message in a yellow bar:

No Plugin Connection. Uploading is disabled until you reconnect.

I have tried reinstalling the plug-in and also restarting browsers, Arduino Uno board and my Mac. No luck.

Any suggestions?

thanks,

Ian

Hi @ianknight,
could you please see if any of the advices at this link can help you? Thanks

Thanks,

Unfortunately these steps make no difference. I’m also working on a Mac, not a PC.

  • Ian

@ianknight I have just tried to reinstall the plugin from scratch on my Mac and it worked w/o issues so let's try to narrow down the cases.

  • Let's focus on Chrome
  • Do you have admin privileges on your Mac? Are you prompted to enter your password within the flow?

Yes, I have admin privileges and I'm asked to enter my admin password twice during the install of the plug-in. I'm confused a bit though, as neither Safari or Chrome list the plug-in after installed. I do have the icon in my menu bar at the top of the screen and it seems to be working (black, versus grey).

Thanks!

Are you able to open this link and see anything?

No, I get a 'Failed to open page' error message.

So the certificate is really not installed on your machine :frowning:
Would you do a screencast of the whole installation process? If you go on Quicktime Player, File > New Screen Recording, you can easily make one. Sorry but we are not able to reproduce on our Macs and will need more infos to debug.

Thanks!!

Thank you so much for your video, one more thing we need you to do to debug this issue.

  1. Go to the Create Plugin tray icon in the upper right corner of your OS, click on it and select ‘Open Debug Console’

  2. A browser window should open up at a page similar to the one attached (the url may vary according to the port your plugin is trying to connect to)

  3. Add https:// at the beginning of the url and add one to the port number (eg. 8992 will become 8993)

  4. Can you tell us what you see?

Screenshot 2017-01-24 10.12.13.png

Screenshot 2017-01-24 10.12.43.png

Thanks, this gives me the same error in both Chrome and Safari.

Are you by any chance behind a proxy?

No, just regular Wifi to a cable connection.

ianknight:
Thanks, this gives me the same error in both Chrome and Safari.

Could you please tell us the point four? 4. Can you tell us what you see?

That means we need to know what do you see while typing https://localhost:8991 or 8992... 8999 until you get a blank page.

It is really important to understand if you get a https error in the chrome browser or you do not even see the blank page.

Thanks!

Hi mastrolinux,

When I visit the url https://localhost:8992/ I got below message

{"Version" : "1.1.60"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "Kelvin-Air.local"}
{"OS" : "darwin"}

When I type list and send, I got below message

{ "Ports": , "Network": true }
{ "Ports": [ { "Name": "/dev/cu.usbmodem1421", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.60", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0043" } ], "Network": false }

My Mac is macOS Sierra 10.12.5 and Chrome is 61.0.3163.100, I can upload code to Arduino when using Arduino IDE or Arduino Web Editor, when I run Arduino extension with Scratch, the connection of Arduino is always disconnected, I am sure no other application is using the port of Arduino.

How can I use ScratchX ?

Best regards,

Kelvin.