MEGA R3 not being recognised - Windows 10


First, my apologies as I see this issue has been raised before but none of the solutions I have tried have worked and I am starting to panic!

Although I am sure it worked when I first purchased it a few months back (I was able to do the built in tests in the IDE), now it's actually time for me to code it for it's intended purpose, and it doesn't work anymore!

When plugging it in (through either USB 3 or 2) I get a message that a usb device was not recognised. Going to Device Manager, there's nothing extra under my ports, but there is an extra USB device titled; Unknown USB device (device descriptor request failed), with the dreaded yellow triangle. Obviously nothing shows up under ports in IDE either. I don't seem to have an 'other devices' category in my DM, which I have seen mentioned a lot in other discussions of the issue.

Things I have tried so far:

  • 2 different windows 10 PCs
  • Installing from the installer package (and checking that the drivers are set to install)(IDE v 1.6.8)
  • Installing from the zip file and manually installing the drivers (IDE 1.6.8)
  • (in all instances attempting to install ANY driver in this process has failed. Windows flat out refuses to accept that the files I am point it to are .inf files)
  • 3 USB cables
  • Front and rear USB ports
  • Un-installing the unrecognised device and unplugging it. Holding reset on the mega, plugging it in and then letting go of reset.
  • Installing CH341 drivers in case my mega is a copy, though I am pretty sure it's not: green power light and all
  • Installing IDE 1.6.5 both from installer and manually

At my wits end and considering downgrading (but is it though?) the PC from 10 to 7 to see if that helps. Any help would be gratefully received. Anyone think they can crack this?