Missing Serial Port for Nano EVEN After Fresh Ide & ch340c Install - Mac

Hi all, happy new year etc.

Really didn't want to add to the million posts on here with a similar problem but I have come to a dead end after hours of trying. Could really use some help.

Arduino Nano clone has a CH340C chip and is not showing in the serial port.

Downloaded the driver to my Mac running Yosemite. Followed the instructions including the use of some terminal code after installing the driver (a requirement for Yosemite users only). Restarted my machine and the Nano still wont show in the serial port.

I've uninstalled everything arduino related and reinstalled it all twice just to make sure it wasn't anything there. I've tried different cables and usb ports. I even plugged in my Arduino Uno in and that works just fine.

I can't update my OS as I'm on a Hackintosh and I don't have another machine to test all the above on and I'm shielding from the virus so human interaction to borrow a machine etc are a non starter.

Appreciate any thoughts. I'm all out of ideas. :confused:

Update to the above post - Turned out it was the cables I tried. Bought a new one and it finally showed on the list of devices… Phew!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.