MKR WAN 1310 no longer shows up in port menu

I have two MKRWAN1310s and have been busy testing/uploading/plugging/unplugging. Suddenly one of them doesn't show up in my port menu. The other one is fine. Tried short and long press of reset button, different USB ports, no difference.

Any suggestions?

One thing I noticed is that on the good one, when I plug in USB the CHG LED flickers really quickly for a few seconds and then goes out. On the one that isn't working, the CHG LED goes on solid (no flickering) and stays lit. I don't know what the significance of this is or if it's related.

mshiloh:
Tried short and long press of reset button

I think you were on the right track!

The tricky thing about the boards with native USB functionality like your MKR WAN 1310 is that the USB code that creates the CDC serial port is running on the same microcontroller as your sketch. This means your sketch code can break the USB code, or stop it from running.

Fortunately, there is an easy way to recover from this situation:

  • Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done)
  • Select the port of your board from the Tools > Port menu. The port number may be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

The upload should now finish successfully. After this, you should be able to go back to doing normal uploads without needing to press the reset button. If you still need to do the reset trick to do uploads after this, the problem may be caused by your code. You can verify this by uploading a simple sketch like File > Examples > 01.Basics > BareMinimum.

Thanks Pert! That's exactly what it needed.

You're welcome. I'm glad if I was able to be of assistance. Enjoy!
Per