Moved topics disappearing?

I've moved two topics earlier on; trying to find them back (using the original URL), I get an "Oops! That page doesn’t exist or is private.".

I moved https://forum.arduino.cc/t/arialmt-plain-16-was-not-declared-in-this-scope/916854 from installation and troubleshooting to programming.

I copied the link from the address bar, closed / opened firefox, paste link and get an OOPS.

I moved another topic from Interfacing w/ Software on the Computer to the Italian section. Don't have the URL but part of the content was

==
Maybe related
The site was in read-only mode for a few minutes at approx. 03:15 SAST.

==
Am I missing something, did I break something or is the site broken?

That link works for me if I click on it in your post or if I copy and paste it into another Chrome window

Thanks, at least I can have a bit of peace. It now indeed works. While posting the opening post, I did verify it again (from the preview) and it did not work.

Note that the link in my opening post stayed as a https URL and did not change to the topic title as it usually does; this might indicate that it could not be found. In your quote it changed as expected.

This is an issue that has shown up before. They, you know who they are, attempted to fix it once before. They might be interested in getting a heads up this issue is happening again.

Now a moved post disappeared again. https://forum.arduino.cc/t/topic/917328; after the move @UKHeliBob's reply initially stayed behind. Pasting the URL again in the address bar of Firefox and"OOPS".

Time to clear my cache and cookies and see if that helps.

OK

Clearing cache and cookies did not help. I've just moved a topic and this is what I see after the move

The opening post has disappeared. So it's not the topic that disappears but the opening post.

Also note that the url (Code Error while compiling - #2 by J-M-L) posted in this reply is not replaced by the by the page title.

And obviously entering the URL in the address bar results in an OOPS.

FireFox on Windows10.

Note: behaviour is intermittent.

@dax1, @alranel

And now it is :frowning:

I see the full thing including the first post under Safari / iOS

(If this is the thread: Code Error while compiling)

Yes it is now; it has happened a few times in the past few days. Initially I thought that the topic disappeared but I've noticed that it's actually the opening post.

There is still something strange, looking up the OP and I don't see created topics

This happens when there are particular background jobs or deploy to be performed.

I can see a very short moment of RO mode around 01:54 UTC

It seems that you are the only one affected by this problem until now. If it happens again could you open the dev console of your browser and send us a screenshot if there are errors in red (you can disable the Warnings in orange).

If there is no error in the Console tab, can you check the Network tab and send us the screenshot if there are any errors?

https://forum.arduino.cc/t/ddrd-was-not-declared-in-this-scope/919969/2, 2021/10/30, 04:50 South African time. Opening post disappeared

After the move

F12 after move

F12 after refresh

F12 after refresh (details)

I hope that this is what you're looking for.

@dax1, and it happened again :frowning: 05:30 SAST, topic https://forum.arduino.cc/t/circuit-and-code-works-in-simulation-but-not-doing-anything-when-done-it-real-life/921971

This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. forum.arduino.cc
Loading failed for the <script> with source “https://connect.facebook.net/en_US/fbevents.js”. forum.arduino.cc:1:1
Some cookies are misusing the recommended “SameSite“ attribute 11
Uncaught Error: Not Found
    t _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:38573
    t _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:38554
    o _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:38537
    trigger _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:71912
    _onError _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:72771
    invoke _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:66550
    flush _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:66442
    flush _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:66646
    _end _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:67222
    end _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:66908
    _run _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:67277
    run _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:66957
    c _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:53706
    error _application-6263f42e69151078caada23e0619b1af99d06ec7a2294c63a19b324a39dd2a7d.js:9993
    u _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:3510
    fireWith _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:3640
    O _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:9802
    n _vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:10061
_vendor-1dab55cf5c2526ab8aee3b22b94132592f09b9633bd10e602dc4fc192e0e5c4b.js:38573:14

The last line is actually at the far right at the same height as the 'uncaught error'

// Additional information
If I try to replyand type @, it does not give the list of users that are active in the thread

Is that Firefox?

Yes. Not sure which version but it is fully patched; Windows 10.

1 Like

Without reproduction steps of the bug it will be difficult to find the cause as only you seem to suffer from this problem.

  • The problem occurred when you tried to move the topic or post to which category (please add the category link)?
  • Is Window10 up-to-date?
  • What version of Firefox are you using?
  • Do you have any extensions installed? If so, which ones?
  • Do you have any ad-blocker or similar programs/extensions installed?
  • Can you try to access the arduino forum with another browser (without extensions / plugins installed) or using an anonymous Firefox window for a few days in order to see if the problem occurs again?
  • If the problem recurs even from an anonymous window or from a different browser, can you access the arduino forum in safe-mode?

Sorry that I might not have been clear about what happens

  • I move a topic.
  • Can't remember exactly what happens if there are no replies yet.
  • If there are replies, the opening post disappears, the replies are visible on the screen (see post #6).
  • Refreshing the page gives me the "OOPS" message; closing / opening Firefox and pasting the URL gives the same result
  • Pasting the URL after that in Chrome also gives me the "OOPS" message.
  • It comes right after a while; I haven't bothered to time it. Might be 5 minutes or an hour or ..., no idea.

Firefox 94.0.1 (64-bit); I use adblock plus and noscript.
NoScript settings:
image

Chrome 95.0.4638.69 (Official Build) (64-bit); adblock plus and noscript installed but not active

Windows 10 up-to-date

Source        Description      HotFixID      InstalledBy          InstalledOn               
------        -----------      --------      -----------          -----------               
I3-2120-WIN7  Security Update  KB4577266     NT AUTHORITY\SYSTEM  2020/11/13 12:00:00 AM    
I3-2120-WIN7  Security Update  KB4580325     NT AUTHORITY\SYSTEM  2020/11/13 12:00:00 AM    
I3-2120-WIN7  Security Update  KB4586864     NT AUTHORITY\SYSTEM  2020/11/13 12:00:00 AM    
I3-2120-WIN7  Security Update  KB4593175     NT AUTHORITY\SYSTEM  2020/12/19 12:00:00 AM    
I3-2120-WIN7  Security Update  KB4598481     NT AUTHORITY\SYSTEM  2021/01/13 12:00:00 AM    
I3-2120-WIN7  Update           KB5000736     NT AUTHORITY\SYSTEM  2021/07/28 12:00:00 AM    
I3-2120-WIN7  Security Update  KB5005699     NT AUTHORITY\SYSTEM  2021/09/15 12:00:00 AM    
I3-2120-WIN7  Update           KB5005539     NT AUTHORITY\SYSTEM  2021/10/13 12:00:00 AM    
I3-2120-WIN7  Security Update  KB5006670     NT AUTHORITY\SYSTEM  2021/10/13 12:00:00 AM   

I will use a private Window in Firefox for a few days and report back.
If the issue happens again, I will try Chrome for a few days.

What is the intention of the safe mode? Do you want me to run it after an issue happens to check if I can see the topic / post? Or run it for a a few days?

We have noticed strange behavior when Ad-block, Noscript, uBlock Origin and other similar programs are used. Sometimes they interfere even if disabled or if the site is added to the allowlist. From the description of the behavior it seems that some external program is interfering with the correct functioning of Discourse.

To rule out that the problem is an internal bug of Discourse, start using anonymous windows (with all the extensions disabled) for a few days to browse and work on the site.

I think @pert may authorize you to experiment with moving topics from one category to another (then you can put them back in the original category).

If the problem does not recur it means that the cause is one of the extensions you are using (I personally have had unexpected behavior with adblock).

Safe-mode will be the next check if we can't find the problem using anonymous windows. Try browsing with anonymous windows first.

Safe-mode disables all plugins and customizations added on Arduino (if they derive from plugins some functions of the site may disappear). Fully enabling safe-mode (leaving the check to all three options that will be given to you) means that the forum will only work with the Discourse core. If with safe-mode enabled the bug does not occur, it means that the problem is in one of the plugins or in the Arduino theme customizations. If it also occurs in safe-mode the problem is in the Discourse core.

1 Like

@sterretje you have my approval to do some experiments like that.

@dax1
Just an update. I did not stop my extensions but used a private browser window. I moved Rfid and 2 push buttons Door lock this morning to "Project Guidance" which went OK; after that I moved it again (to follow UKHeliBob's move) and the opening post was missing. A page refresh resulted in "OOPS". Time approx. 06:20 SAST.

As usual, I tried to find the topic back in Chrome (no extensions) which also resulted in "OOPS".

I also tried to find the topic using Chrome on my Android phone (and a different ISP) with and again "OOPS"

So although my PC setup (Win10 / Firefox) might be causing the problem, there is something in the backend else I would not have the problem in another environment (cell phone).

At 06:45, I tried again on the cell phone and the topic was found; same in Firefox on the PC, topic is fully there.

I've now disabled ABP and see how that will work.

Notes:

  1. I've never encountered the problem when moving topics using my cell phone; should have mentioned that before (sorry).
  2. //edit: I move topics regularly and it does not happen every time, should have mentioned that as well.

@dax1 and @pert, I'm not very eager to move topics around for no reason; if it fails, I can't inform users that it was moved. I will see if I can find some of my own old topics and move them around.

@dax1

Just moved IDE 2.0 saving and opening behaviour using chrome on an android phone and it happened as well. This is the first time that it happened with the phone; using same ISP as with the PC.

No additional extensions installed in chrome.

Will have to read up on safe mode.