My Arduino does not appear in COM ports on device manager or arduino

My arduino pro micro was working fine until recently, I had uploaded multiple sketches over about a year. Recently, I started tinkering with a button (I worked mostly with a serial interface beforehand) and an LED light. I fried a few of these LEDs using power directly from the VCC pin of my arduino into a breadboard. I read that sometimes putting power into the reset pin will help, but there is no noticeable change with the onboard LEDs (which remain on). I can still use the arduino for power for the breadboard, but I cannot upload any new sketches, which is a problem. I am using Windows 10 64 bit and have reinstalled the arduino IDE, which (I think) should have reinstalled the drivers for the arduino.

Thanks, James

Hi Have you already tried in another computer, could be a windows driver problem...

(deleted)

I have now tried it completely disconnected from the breadboard, and no such luck. The device still does not appear in device manager. Thanks for your help guys, I'll just buy a new one as they're so cheap.

Thanks :) , James