nano driver error

Hi, since the latest WIN 10 64 (Fall Creator's) update on my Toshiba Laptop my USB driver no longer works for nano V3 (FTDI FT232RL chip).

When attempting to update driver thru Device manager I get Error message "The hash for the file is not present in the specified catalog file. The file is Likely corrupt or the victim of tampering."

I am using the latest build IDE 1.8.5 WIN10 zip version which I downloaded and installed today.

So, where to from here?

Thanks for any useful answers.

Maybe it’s this in some form:

Thanks 6v6gt for your informative reply and link -very useful, although I consider my board is 'genuine' i.e., a duinoTech V3.0 nano from a reputable Oz dealer, over the counter. The top chip is an Atmel Mega328p, and the bottom chip marked as FDTI FT232RL. The annoying aspect is that it had worked well until the latest WIN update and the drivers all looked to be as specified - they simply won't load ergo the error as quoted in my post. From a software perspective it appears that the latest drivers have a flaw with a missing operator? I am absolutely sure I have done nothing that could have 'fried' the board otherwise. I know programming and connections etc., can be frustrating (I have worked with micro's before) but this is really pushing the boundaries!

Thanks again for your help.

although I consider my board is 'genuine' i.e., a duinoTech V3.0 nano from a reputable Oz dealer, over the counter

It is not a genuine Arduino and it looks like they sourced fake chips to build it.

It is a clone, but not a forgery. That is, there is no attempt to claim it is a genuine Arduino manufactured product and it is marked with the brand name Duinotech.
However, it could well, as has been said, be built using components which have been forged. If the dealer is reputable, they will have a solution for this if indeed the problem is a fake FTDI chip.

Thanks to those who have contributed to my question. It is still not resolved, so I will continue my search and programming. I am away from home temporarily so I will check the nano out when I get back to my desktop - if no go, I shall replace it with a UNO at least.
Thanks again,

Try getting the latest FTDI driver from

Thanks to all those who offered help. However, upon returning home and connecting the nano to my desktop PC, also running WIN 10 Pro 64 (updated), the board worked fine and two ports were visible COM 1 & 3.

It would appear that for some unknown reason my laptop refuses to recognise ports??

(I intend to chase this up with Toshiba).

I trust this info may help others with similar Laptop issues.

Cheers, :slight_smile:

Were you using a USB 3.0 port on the laptop? They have been known to cause odd problems where USB 2.0 works perfectly.