Necesito ayuda, por favor.

Hola a todos. Hace años estudié electrónica (Técnico Especialista) pero no me dediqué a ello profesionalmente. Siempre me apasionó la electrónica y ahora intento ponerme al día de cosas tan maravillosas que han salido desde entonces como el arduino. Pero no tengo ni idéa de programar. ¿Alguien está dispuesto a echarme una mano? ¿Por dónde empiezo para aclararme con este lío de la programación? Muchas gracias de antemano. salascortes@hotmail.com

En la página principal tienes muchos ejemplos para empezar a comprender la estructura de programar en C. Y por google tienes miles de manuales. pero yo te aconsejaria mirarte y hacer varios ejemplos de los que hay en la pagina.

Un saludo

Hola "Novato"!!

El que no tengas ni idea de programación es una limitación importante, pero si estás dispuesto a aprender, no es imposible. Te va a costar un poco, pero merecerá la pena.

Debes empezar desde muy abajo, con algún libro básico y muuuucho google.

Una vez que tengas las nociones básicas de programación, debes visitar la página http://www.wiring.org.co/

Y por supuesto también: http://www.arduino.cc/es/

Suerte y no lo dejes. Pregunta lo que quieras.

Saludos, Pakoff.

Gracias a los dos. Me paso las horas googleando y viendo páginas y páginas. En español pocas y de inglés "ni papa, niño!". Mañana me llega mi arduino. Empezaré con algunos ejemplos e indagaré más sobre el tema. Tal vez me saque de la biblio algún libro de C. Saludos.

Ya verás como en un par de meses estás cacharreando tu solo. Lo más importante es que no desistas..

Bye. Pakoff.

Acabo de comprar una placa Arduino Duemilanove y tengo el siguiente problema: Al hacer el primer ejemplo (Led parpadeante entre los pines 13 y GND) dicho led parpadea pero hay un momento (tras 8 ó 9 encendidos) en el que el ciclo se detiene para reiniciarse 2 segundos después. Durante esta pausa se encienden los led's de la placa, como si estuviera "pensando". ¿Esto es así o estoy haciendo algo mal? La alimentación de la placa es por USB. De ser así esta placa no me sirve. Ruego que me ayuden o aconsejen. Muchas gracias de antemano.

Entiendo que ese funcionamiento no es normal.

Intenta alimentar tu arduino mediante el conector externo y resetéalo. Déjalo funcionar sin tocar nada y sobre todo que no pueda haber ningún falso contacto.

Saludos, Pakoff.

Ya lo hice así esta tarde y va de maravilla. Debe haber algún problema con el PC si lo “runeo” y lo alimento por USB.

Una pregunta más… ¿Cuános leds puedo conectar a una sola salida? Lo pregunto porque necesito conectar en cada salida grupos de 5 leds y no se si me agüantará la intensidad. Si no puedo hacer esto ¿cómo puedo conseguirlo? Algún esquema me vendría bien (sin relés). Muchas gracias.

Hola,
por lo que acabo de leer en el datasheet de atmel para el atm238 de tu duemilanove, tienes una intensidad máxima de salida de 40mA por pin I/O. Dependiendo del led que vayas a poner (los típicos unos 20mA), yo de tí no ponía mas de 2 en misma patilla (de hecho yo sólo ponía uno). Lo mejor sería que te pillaras un integrado con optoacopladores o relés en cualquier integrado a 5V, y ahí conectaras lo q quisieras, ya que así no cargas la salida de los pines del micro.
En casa no tengo ningún programa para diseñar circuitos, si ves que no eres capaz lo hago aunque sea a mano.
Un saludo

Gracias, Bodhi. Había pensado en adjuntarle un ULN2803A, pero en su datasheet pone, el la tensión de entrada: 15/30 V. No sé si trabaja sólo a esas tensiones o son mínimas (15 V.) y máximas (30 V.). ¿Sabrías sacarme de esa duda? Gracias.

Hola, he estado mirando el datasheet, y no encuentro lo que comentas de 15/30V. He visto que la tensión máxima de entrada es de 30V y la máxima de salida es de 50V. No se cual es la mínima, pero supongo que viendo el darlington del datasheet estará en torno a 3V, por lo que con los 5V de salida del arduino tienes suficiente.

Hola, de nuevo. Tengo dos serios problemas: Alimento mi Arduino a 16 Vcc y sólo obtengo salidas de 5 V. ¿Esto es así?. Y el segundo: le he acoplado un ULN2803A. También a 16 Vcc (Negativo pin 9 y Positivo en pin 10). Del pin 8 de Arduino conecto un cable al pin 1 del integrado. A la entrada del mismo tengo 5 Vcc, pero a la salida 0,6 Vcc. ¿Qué está pasando? Alguna ayuda que me anime?

Y si sólo obtengo 5 Vcc de la Arduino y quiero encender una bombilla que funciona a 12 Vcc... ¿Cómo puedo conseguirlo? Muchas gracias de antemano.