Partitore tensione…ma i fili si squagliano

Buongiorno a tutti…ho progettato e messo in funzione (in beta test) una piccola centralina di controllo per camper.
Fra le cose che dovrebbe fare c’è la visualizzazione della tensione dalle due batterie servizi montate…la tensione viene trasformata da un partitore di tensione costruito con i pezzi che avevo in casa e formato da 3 resistenze da 10.000 ohm in serie più una da 10.000 ohm e un condensatore.
Così facendo funziona sia teoricamente Vbc=15 (volt batteria)*(30.000/10.000)=5 v
che realmente.

PROBLEMA: oggi non mi dava i valori di tensione di una delle due batterie così ho aperto il cofano ed ho trovato il filo collegato al polo positivo completamente fuso e rotto…la guaina del filo negativo è visibilmente “cotta” ma non sciolta.

Considerate che sono fili del tipo LAN CAT 5 molto fini ma partivo dal presupposto che vista l’esiguità della corrente che doveva passarci, sarebbero andati benissimo.
Ho verificato anche l’altra batteria ed ho trovato la guaina del filo negativo visibilmente “cotta” ma per il resto tutto ok.
In cosa sbaglio???
Grazie a tutti coloro che vorranno rispondermi…

IMG_5943.JPG

sinceramente non capisco il perché dei valori di quelle resistenze, poi la capacità la lascerei perdere.... fai un partitore con rapporto 10 a 1, per esempio una res da 1 k e una da 100 ohm. Consiglio personale, installa un trimmer tra le due resistenze se proprio vuoi fare una taratura molto precisa aiutandoti con un multimetro. Per sicurezza ti consiglio di installare nel partitore un diodo zener da 5.1V 1/2W per salvaguardare Arduino. Se qualcosa và storto nel partitore addio Atmega

gironico:
sinceramente non capisco il perché dei valori di quelle resistenze, poi la capacità la lascerei perdere.... fai un partitore con rapporto 10 a 1,

Beltin ha seguito la giusta strada sia come valori di R che per il condensatore in parallelo su quella verso GND.
Perché i fili sono fusi può dipendere da un corto tra il cavo collegato al positivo e la lamiera del veicolo, che è a GND, basta un piccola parte di guaina che non copre perfettamente il rame ed è un attimo fare il corto.

Qualche dubbio lo avrei sulle "due batterie servizi": come le hai collegate rispetto alla principale ed all'alternatore?

Per evitare squilibri (ed incendi), si dovrebbe usare un ripartitore di carica.

Grazie a tutti per le risposte…allora cerco di rispondere:

  • ho usato resistenze di alto valore resistivo perndando così di limitare al massimo la corrente di passaggio nei fili...

astrobeed:
...
Perché i fili sono fusi può dipendere da un corto tra il cavo collegato al positivo e la lamiera del veicolo, che è a GND, basta un piccola parte di guaina che non copre perfettamente il rame ed è un attimo fare il corto.

  • OK ma non capisco perché nell'altra batteria, il filo del negativo sia visibilmente deteriorato anche se non squagliato….

cyberhs:
Qualche dubbio lo avrei sulle "due batterie servizi": come le hai collegate rispetto alla principale ed all'alternatore?

Per evitare squilibri (ed incendi), si dovrebbe usare un ripartitore di carica.

  • Le batterie servizi sono collegate ad un tipico caricabatterie da camper tramite un selettore col quale decidi quale batteria usare…la batteria motore è anche questa collegata al caricabatteria tramite un ripartitore che lo scollega quando il motore è acceso, usando così l'alternatore.

altri dettagli che potrebbero aiutare sono che i fili:

  • hanno una lunghezza totale di approssimativamente 2 mt. uno e 3 mt. l'altro;
  • si sono squagliati dal polo della batteria fino al punto in cui i fili, rientrando nella guaina della cavo tipo CAT.5, si avvinghiano l'uno con l'altro…all'interno della guaina poi sono OK.

io penso che se non c è stato corto forse i fili cat5 non sono fatti per resistere ad elevate temperature e magari li hai fatti passare in un luogo infelice... perché sulla carta li non passano ampere....
lo zener comunque non fa male. non dovrebbe servire ma se c'è...
mi pare comunque che un piccolissimo zener sia gia piazzato nella scheda arduino? mi sbaglio?

Anche io l'ho pensato ma le due batterie sono in posizioni molto diverse:

  • una nel vano motore (ed è quella che si è squagliata)
  • una sotto il sedile passeggero (il cui filo del polo negativo è "cotto" ma non squagliato)

Ad essere pignoli, giusto per rispetto della teoria

Così facendo funziona sia teoricamente Vbc=15 (volt batteria)*(30.000/10.000)=5 v

per ottenere 5v in uscita dal tuo partitore devi applicare all'ingresso 20V e non 15V, hai messo una resistenza di troppo.

La formula corretta è: Vbc=20 (volt batteria) / ((30.000+10000)/10.000)=5 v

Potresti comunque lasciare tutto com'è e compensare l'errato rapporto di riduzione via software anche se perdi in modo ingnificante la precisione.

Per quanto riguarda la scelta del cavo di CAT5 collegato direttamente ad una batteria, sono molto critico e direi che non si deve mai fare!!

Non tanto per la corrente che stai utilizzando che è a dir poco insignificante, quanto per l'eventualità che un possibile danno all'isolamento del cavo trasforma lo stesso in un vero fusibile (come ipotizzo sia avventuo nel tuo caso). Probabilmente sei stato anche fortunato che l'evento non abbia provocato altri dammi molto più seri.
Le batterie per autoveicoli hanno una corrente di cortocircuito molto elevata, e su ogni linea in partenza dal polo positivo deve essere dotata di apposito fusibile.

La mia proposta:

  • sposti una delle resistenze da 10k proprio a ridosso del polo positivo della batteria.
    In questo modo il rapporto del partitore rimane inalterato, risparmi di inserire un vero fusibile e portafusibile e sei tranquillo che qualsiasi cosa succede a valle non hai nessun problema, in quanto la resistenza da 10k limita la corrente a pochi uA.

  • opzionale, ma consigliato utilizzi dei fili da 0,75-1 mm2 esclusivamente per aspetti di robustezza meccanica e sposti comunque la resistenza (come detto).

Grazie lelebum, mi sembra una proposta sensata! Proverò a fare così...

qsecofr:
io penso che se non c è stato corto forse i fili cat5 non sono fatti per resistere ad elevate temperature e magari li hai fatti passare in un luogo infelice... perché sulla carta li non passano ampere....
lo zener comunque non fa male. non dovrebbe servire ma se c'è...
mi pare comunque che un piccolissimo zener sia gia piazzato nella scheda arduino? mi sbaglio?

In questo caso l'applicazione dello zener nel partitore, serve per salvaguardare il pin analogico se il partitore dovesse a causa di un guasto lasciar passare tensioni superiori a 5V. Il microcontrollore si guasterebbe.

gironico:
se il partitore dovesse a causa di un guasto lasciar passare tensioni superiori a 5V.

Sugli AVR ci sono i diodi di clamping su tutti i pin, ci pensano loro ad evitare danni in caso di tensioni superiori al massimo ammesso, ovviamente ci deve essere una resistenza in serie che limita la corrente, se non c'è anche lo zener va nel paradiso dei componenti assieme al pin e/o tutto il micro.
Semmai è il caso di mettere dei transil, non per un ipotetico guasto del partitore, ma per gli spike ad alta tensione, anche molte decine di volt, sempre presenti sugli impianti elettrici automotive, un normale zener non serve a nulla in questi casi.

Semmai è il caso di mettere dei transil

Scusa la mia ignoranza, ma cosa sono i "transil"?

Forse intendi gli scaricatori di tensione?

gironico:
sinceramente non capisco il perché dei valori di quelle resistenze, poi la capacità la lascerei perdere.... fai un partitore con rapporto 10 a 1, per esempio una res da 1 k e una da 100 ohm. Consiglio personale, installa un trimmer tra le due resistenze se proprio vuoi fare una taratura molto precisa aiutandoti con un multimetro. Per sicurezza ti consiglio di installare nel partitore un diodo zener da 5.1V 1/2W per salvaguardare Arduino. Se qualcosa và storto nel partitore addio Atmega

Stai sbagliando Tu.

Il condensatore serve per avere la carica per caricare il condensatore Sample&Hold all interno del convertitore ADC.
Il valore delle resistenze é giusto perché con valori piú bassi scarichi di piú la batteria.

Il diodo Zener conduce giá sotto 5,1V e percui se si usa uno la tensione massima misurabile sará intorno ai 4,5V. è meglio collegare un diodo skotky in polaritá inversa tra l' entrata Arduino e +5V (catodo verso i 5V)

Ciao Uwe

astrobeed:
Beltin ha seguito la giusta strada sia come valori di R che per il condensatore in parallelo su quella verso GND.
Perché i fili sono fusi può dipendere da un corto tra il cavo collegato al positivo e la lamiera del veicolo, che è a GND, basta un piccola parte di guaina che non copre perfettamente il rame ed è un attimo fare il corto.

Scusami astrobeed
Se si avesse fatto un corto verso massa (lamiera della carosseria non si sarebbe fuso il polo negativo del cavo ma solo il positivo.

Deve esserci un corto tra il cavo 12V e il cavo negativo che porta la tensione dalla batteria alla schedina partitore resistivo.

Ciao Uwe

lelebum:
Scusa la mia ignoranza, ma cosa sono i "transil"?

Forse intendi gli scaricatori di tensione?

sono dei diodi zener con catteristiche particolari; agiscono in tempi molto veloci e possono scaricare potenze nel ordine di kW per brevi tempi nella grandezza dei µS.

Ciao Uwe

beltin:
altri dettagli che potrebbero aiutare sono che i fili:

  • hanno una lunghezza totale di approssimativamente 2 mt. uno e 3 mt. l'altro;
  • si sono squagliati dal polo della batteria fino al punto in cui i fili, rientrando nella guaina della cavo tipo CAT.5, si avvinghiano l'uno con l'altro…all'interno della guaina poi sono OK.

Presumo che togliendo l' isolazione esterna hai danneggiato l' isolazione del doppino (cavetti attorcigliati) che é andato in corto.

Ciao Uwe

Il componente "Transil" mi era sconosciuto, e così oggi ne ho imparato una di nuova.

Sopratutto giunge a proposito ed essere risolutivo per un problemino che ho in questi giorni.

Grazie mille