Please Help! ERROR: Incorrect IDE Installation folder. (MAC OS)

Hi everybody!

I know this is not the first time this’s been asked, but after reading all the other posts (including the ones in this forum) i couldnt manage to solve the problem :frowning: .

I had a previous version of arduino ide installed on my mac (OS X Mavericks), working properly. But yesterday I downloaded the last version (1.8.1) and after installing and when trying to open the app, the following error pops up: “Incorrect IDE Installation folder - Your copy of the ide is installed in a subfolder of your sketchbook. Please move the IDE to another folder.

Any ideas where should i unzip the Arduino.dmg , I’ve tried differents paths but none of the seems to work.

Cheers!

Iggy

Screen Shot 2017-01-31 at 8.32.33 AM.png

You can check and/or change the location of the sketchbook folder at
/Users/(username)/Library/Arduino15/preferences.txt

Legend!

Finally i deleted from the library the Arduino and Arduino15 folders, that belonged to the previous version. Reinstalled the new one and worked.

Cheers,

Iggy