Port: USB non reconnu Voyant L qui clignote

Bonjour,
La semaine dernière j’ai dû faire une mauvaise manip et ma carte arduino UNO a cessé d’être reconnu.
Je l’ai donc considérée comme grillée et j’en ai commandé deux neuves (MEGA et NANO).
Ce sont des cartes génériques (http://www.ebay.fr/itm/272055682564?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT)

Le problème que je rencontre est étrange car le problème persiste avec ces deux cartes que j’ai testé “à vide” sans aucun montage juste la carte branchée en USB sur mon mac.

Dans le menu “outil/type de carte” je choisis la bonne carte
Dans le menu “outil/PORT” seul “bluetooth” est dispo. “port série” est en gris
Le voyant L de la carte clignote sans discontinuer. Le voyant ON est allumé en continu.

Auriez-vous des idées à me suggérer?
Merci par avance.

Bonjour,

Par défaut les cartes sont chargées avec le bootloader et programme blink (enfin la plupart), donc ce n'est pas anormal que la led L clignote.
Pour ton problème je penserait plutôt à un problème de driver, mais je ne suis pas utilisateur de mac.

Merci pour ta réponse.
Quelqu'un peut me renseigner sur d'éventuels problèmes de drivers?

J'ai trouvé la réponse à mon problème (presque) tout seul.
En effet Kamill, il s'agissait bien d'un probleme de driver.
J'ai trouvé ceci: CH341SER_MAC.ZIP - 南京沁恒微电子股份有限公司
Je l'ai installé et rebooté le mac.
Maintenant tout fonctionne.
Merci de m'avoir mis sur la bonne voie.

Si ce que tu indiques est exact, alors sur le fond ton problème est assez inquiétant.

Non.
Premièrement tu as tout à fait raison quand tu parles des possibilités d’extension de service avec le 16U2 comparé à un circuit dédié à l’interface USB/UART qui est figé.

Mais à cela j’ajoute :

  1. je n’ai jamais lu le moindre écrit sur des réalisations utilisant cette possibilité. Sans aucun doute certains ont pu le faire mais c’est resté d’une confidentialité digne d’une tombe.
  2. le 16U2 apporte des possibilités mais il prive aussi des autres signaux qu’apporte une interface USB/UART, même s’il est vrai qu’aucune carte Arduino ne les a exploité.

Pour moi le choix de remplacer le circuit FTDI de la Duemilanove par un atMega16U2 dans la UNO/MEGA est uniquement financier : ftdi a exagéré avec le prix de vente de ses circuits et Atmel à fait une ristourne si Arduino lui achetait 2 CI par carte au lieu d’un seul.

C’est donc tout à fait dans l’esprit arduino que les fabricants chinois, qui cherchent à réduire les coûts, soient resté dans la continuation de la carte Arduino Duemilonove qui utilisait un circuit USB/UART.
Le ftdi a été remplacé par des SECONDES SOURCES et non pas des copies ou des clones, termes que je considère comme péjoratifs car le CH340G n’utilise pas le pilote ftdi mais sont PROPRE pilote, ce n’est donc ni une copie ni un clone.
C’est une règle de base dans l’industrie : il ne faut pas être tributaire d’un seul fournisseur. Il n’y a d’ailleurs pas que le CH340/341G il y a aussi le circuit Prolific.

C’est pour moi anormal qu’Arduino n’ai pas fait cette opération de réduction de coût.
Pour l’expliquer j’ai deux hypothèses :

  • le contrat signé avec Atmel ne leur en laissait pas la possibilité.
  • ils n’ont plus rien à faire des cartes basées sur des avr, c’est la vache à lait : on tire dessus le plus possible tant que cela fonctionne.

Et c’est bien le dernier de leur soucis que les clients soient obligés d’ajouter le pilote du ch340g, surtout que sur ce point aussi ils ont peut-être signés des contrats avec FTDI qui leur lient les mains. Utiliser un autre principe cela peut passer, accepter un concurrent là ça coince.

Faut-il aussi préciser que la carte nano n’est pas une création Arduino mais Gravitech.
Arduino c’est des grosses cartes car le modèle économique d’Arduino c’est de vendre des shields.

Bon, j'ai pas tout pigé à vos posts (je suis débutant). Ceci dit, le pilote installé, cela semble fonctionner correctement, sauf... peut être, à plusieurs reprises, mon mac à rebooté automatiquement lors du débranchement usb de la carte (peut être lié à mon montage).

Si le fait que cette puce soit intégrée sans que cela soit spécifié à la vente, ce n'est pas le cas pour la carte nano que j'ai acheté chez le même vendeur

http://www.ebay.fr/itm/Arduino-Nano-3-0-compatible-CH340-non-soude-/272047790903?hash=item3f574fdb37:g:BiEAAOSwv0tVMBXD

alors, oubli ou arnaque?

le prix, en même temps, n'est pas élevé (13.90 pour la MEGA et 4.90 pour la NANO sans frais de port)