portable ide installation problems

When I double click on Arduino (executable) there is a warning first "the usb stick contains software intended to be automatically started. Would you like to run it?"
When I click run the error given is "Oops! There was a problem. Unable to locate the program"

The instructions in https://www.arduino.cc/en/Guide/PortableIDE seem straight forward.
I downloaded the linux 64bit from https://www.arduino.cc/en/Main/Software
(I did see some notes about a windows portable version - this inux version has install.sh files etc. I did not run them.)

The tar file was copied to the ext4 formated USB and extracted.
Portable directories were added, then I double clicked on Arduino as above on the USB stick.

Do these instructions work for you? or do you do something else too.
When it says "Unable to locate the program" how do I identify what program it is looking for?
I assume that knows where Arduino is and that Arduino is trying to run another program.

There is the possibility that a simple extract is not enough - the first time I tried on this computer the executable bit was not set on the Arduino executable or the install.sh files.

I have not installed the Arduino IDE on this computer - I thought it is supposed to run off the usb stick.


I use the IDE version for Windows with the portable folder. The difference between being portable or not is in the portable folder itself, which allows files to be concentrated in one location within the IDE's own file structure.

I believe there is a need to perform some procedure so that the executable can be launched, because to run in linux I needed to follow some installation tutorial, unlike Windows, you can't just click on an .exe file. Although I have not used the portable folder in linux (Xubuntu), I believe that after the installation is functional in linux, it will be possible to create the portable folder and then follow in a similar way to what is done in Windows.

Try to follow some tutorial for installation in linux, and maybe modify the destination folder to the location you want, such as removable media etc.

Tried running install.sh

$ sudo ./install.sh
Adding desktop shortcut, menu item and file associations for Arduino IDE...

ln: target '/usr/local/bin/arduino' is not a directory
Adding symlink failed. Hope that's OK. If not then rerun as root with sudo.


That appears to mean it is installing into the regular file system. One of my main reasons for going portable was because copying the executables onto the usb implied that I would be running off of the usb and could then install only the target board and libraries. I hate those messages saying I found 6 copies of this file and I, the compiler, am picking this one.

Still get the "unable to locate program" message.

Maybe we can break the problem down into smaller bits.

What does the "contains software intended to be automatically started" message mean? Is this normal? Why does it happen?

Searching on the forums does not show an identical message.

Still trying.

Using a fresh laptop. No Arduino IDE install on it.

Tried installing to a USB stick - got hard link error on bin/arv-ld
Reformatted USB to NTSF file system - can't use fat32

The portable guide says simply "To use this installation, launch the Arduino executable;"
Are we talking about install.sh or arduino - all the files are set to executable

Could not run install via file explorer - used terminal/console

launched ./install.sh - got soft link error
launched sudo ./install.sh - took a long time but reported as ok.

launched arduino via file explorer - get the message above - contains software intended to be automatically started. Would you like to run it? - chose run - opps there was a problem running this software. Unable to locate the program.

Went to desktop - arduino icon showed as a ? - double clicked and was told this is not a trusted application. Would you like to trust it? - said yes - now the icon is called arduino IDE but it won't run - no error messages.

Ran ./arduino from terminal - ./arduino: line 35: /media/christopher/ArduinoIDEportable/arduino-1.8.12/java/bin/java: No such file or directory

So now I am wondering which Java to install & how to specify the old one needed. any suggestions?
Hmm I had noticed that the directory list did not include Java when I added the portable directory.

If I open a terminal & type java --version I get

java --version
openjdk 11.0.6 2020-01-14
OpenJDK Runtime Environment (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1)
OpenJDK 64-Bit Server VM (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1, mixed mode, sharing)

So I have java installed. Am I to turn the java into a link pointing to the fixed disk location or do I install another copy on the usb key?

Before trying portable mode, you might be able to try non-portable mode. The portable mode few people use. If the normal, non-portable mode also doesn't work, there may be some changes to the operating system that need to be worked around.