problem with the installation, no serial port shown in IDE(tools)

Hi!
I made a search on google before this threads, as my problem is not solved yet.
Because this is my first project on Arduino, I apologize for my lack of skills and possible not understanding of the future advices.
I followed a book tutorial, but I started having problem when I connected my Arduino board to my computer(windows 10). In fact, the automatic installation didn’t start, so I proceeded with a manual one following the advices found in http://www.arduino.cc/en/Guide/Troubleshooting#upload
I did it, but the computer considers my arduino as Arduino DUE, while I have an Arduino UNO. (see the picture)
Then, IDE doesn’t find any serial port and when I tried to upload it on my board, it showed this error:

Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino Uno"


Sketch uses 1016 bytes (3%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "\\.\COM3": The system cannot find the file specified.


Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

What I can do?

The CaptainNik

P.S.: I found in a similar thread that a possible problem could be CH340 driver, but even if I installed it the problem is still there.

Cattura.PNG

There are three things you can try.

  1. Install the IDE with administrator privileges.

  2. Ensure any additional security / antivirus is turned off. If that works by itself then add the Arduino install to your computers security whitelist / exclusions.

  3. Disable driver signature checking. You can re-enable after you verify the install works.

It may be that you end up doing all three but normally (1) would suffice.

Bob.

Thank you for your answer!

However, the first point is what I already did when I installed IDE the first time. To be sure, I reinstalled but the problem is still there.

I repeated the procedure for the device manager drivers and I found Arduino UNO finally. the icon however is still with a triangle, what is the meaning of that?

I will try the 2nd and 3rd point soon, I just need to understand how to do them!

Google is your friend.

Disable driver signature

As for turning off the additional security you may have then you would have to tell us what it is you are using.

The triangle usually indicates a driver issue. Either the wrong one or none installed. Or currently not ENABLED.

Bob.

Thank you, Bob.

Actually, I have Avira as antivirus, the free version of course. I stopped it for a moment and I connected Arduino board and nothing happened, so I will try with the last advice disabling driver signature. I will supposedly use the first the first method explained in your link.

Unfortunately, I don't have so much time to dedicate it, so I'm going to work on that slowly.

Nik

Hi!

I finally solved, but yet I don't understand why.

Basically, I simply tried a different Arduino board. This worked with no problems, but the most astonishing part is what happened after: my board has been working since then.

Nothing really changed, but now it is working.

Thanks for your help, Bob.

Nik