Problema caricamento sketch

Salve,
ho un problema nel caricare gli sketch: una volta scritti e compilati, quando provo a caricarli sulla scheda(arduino nano 328) continua nel caricamento ma nonn li carica mai. Mi dice che c’è un errore, a volte avrdude: ser_recv(): read error: Acceso negato e altre volte Error abriendo puerto “COM18” (Port busy). Ho provato a cambiare entrata usb, cavo e anche arduino, ma comunque non cambia nulla.
Quale potrebbe essere il problema?

Stai usando Arduino cinesi ? Non so se ricordo male, ma dovrei aver avuto i tuoi stessi errori anni fa quando ho iniziato a giocare con questi cosi,sempre nel caricare sketch. Controlla i driver usb della tua scheda madre, quando è successo a me, ho dovuto aggiornarli tramite il sito Asus perchè dopo 10 anni ne erano usciti di nuovi proprio per questo problema.

VittoM: Salve, ho un problema nel caricare gli sketch: una volta scritti e compilati, quando provo a caricarli sulla scheda(arduino nano 328) continua nel caricamento ma nonn li carica mai. Mi dice che c'è un errore, a volte avrdude: ser_recv(): read error: Acceso negato e altre volte Error abriendo puerto "COM18" (Port busy). Ho provato a cambiare entrata usb, cavo e anche arduino, ma comunque non cambia nulla. Quale potrebbe essere il problema?

Ciao potrebbe essere che il nano abbia a bordo il vecchio bootloader. Hai provato entrambi?

tools-->processor-->attmega328p tools-->processor-->attmega328p (old bootloader)

VittoM: read error: Acceso negato e altre volte Error abriendo puerto "COM18" (Port busy). Ho provato a cambiare entrata usb, cavo e anche arduino, ma comunque non cambia nulla. Quale potrebbe essere il problema?

Ma sicuro che Arduino viene visto proprio come COM18? Magari non è che hai cambiato porta USB e quindi è un'altra COM? Apri Gestione periferiche e vedi cosa compare quando inserisci il cavo, ossia quale COM si attiva.

PS: perché hai i messaggi in spagnolo?

Ho risolto selezionando old bootloader Ho i messaggi in spagnolo perché al momento mii trovo in Spagna

VittoM: Ho risolto selezionando old bootloader

Ah bene meglio così.

Ho i messaggi in spagnolo perché al momento mii trovo in Spagna

Non andare mai in Cina o in Egitto allora... :)

(non vedo che c'entri dove ti trovi fisicamente, con la lingua dell'IDE, comunque ok... :D ).