Problemas con un Arduino UNO genérica (o posible falla de mi computadora)

Hola a todos!. Esta es mi primera vez posteando en el foro, y mi primera vez mirando de reojo al mundo de Arduino.
Iré al grano, tengo un problema con una Arduino UNO genérica (basado en el CH340), que en la primera semana de uso funcionaba excelente.
Hace poco tengo problemas para que mi computadora (Windows 10) lo reconozca, puesto que solo algunas veces reconoce la tarjeta y luego al cambiarla de puerto, me salta el mensaje "Windows no reconoce al dispositivo".

Me dirijo a "Administrador de Dispositivos" para ver la conexion Arduino / PC y los drivers están en perfectas condiciones, pero mas al costado me señala "Error relacionado a la solicitud del decriptor", o algo asi señala con un simbolo de advertencia.
Intenté reinstalar los drivers pero permanece el problema.

El IDE que tengo instalado es oficial y es la ultima versión que proporciona la web de Arduino, junto con los drivers que trae incluidos en el EXE.

Ojalá puedan darme una mano, ya que me estaba entreteniendo bastante con la placa

Me parece recordar que es un problema con Windows 10, que a pesar de que ya instalaste el dispositivo, actualiza el driver por otro y asi y adeja de funcionar, si mal no recuerdo puedes econtrar un tutorial de como desactivar la actualización automatica de drivers de Windows 10, hay un video en YT, pero no recuerdo si es en español o ingles.

Suerte.
-Alex.

Hi,
Yo tuve ese mismo problema hasta que consegui el driver chino. Adjunto el link donde lo puedes bajar. Si vaz a instalar remueve el que tienes instalado.Luego instala el chino. Posiblemente no te resuelva el problemas pero este me resolvio el mio y nunca he tenido mas problema. Para bajarlo dale click en el cuadro azul.
.CH341SER.EXE - 南京沁恒微电子股份有限公司