Problème RTC DS3231

Bonjour,

Dans mon projet j'utilise un module RTC DS3231 comme celui ci :

Tout fonctionne correctement mais depuis hier elle déconne.
La LED rouge du POWER ne reste pas allumé et clignote et parfois l'heure affiché sur mon écran et 33:00:00 après actualisation de mon programme (1s) l'heure affiché et de nouveau la bonne.
Le 33:00:00 peut ne pas revenir pendant un moment ou revient de temps en temps c'est plutôt embêtant.

La seule modification que j'ai effectué sur le module et de soudé 4 broches sur les bornes supérieur peut être une soudure mal faite ?

J'ai aussi changé la pile mais c'est toujours pareil.

Mon module est-il en train de rendre l'âme tout doucement ? Avant d'en recommandé un je voudrais avoir votre avis.

Merci

Salut
Le module est-il monté sur breadboard ?
Peut-être un mauvais contact sur l’alimentation ?

@+

oui il est sur ma breadboard mais j'ai rien changé depuis le début que je m'en sert à part avoir soudé les 4 broches au dessus qui pour l'instant ne servent pas

Un examen à la loupe des soudures permet sans doute de le vérifier :

  • soudure sèche, ça forme une bille d'étain sur le pin mais on a un mauvais contact intermittent avec la pastille du PCB.
  • soudure baveuse, elle déborde sur la piste d'à côté et fait un pont indésirable.

hello
je te cite

"J'ai aussi changé la pile mais c'est toujours pareil."

ce n'est peut être pas ta solution, mais c'est un accu qu'il faut, pas une pile

La pile est juste là pour alimenter le DS3231 en l'absence de VCC.
Quand il est alimenté normalement, même en enlevant la pile, le DS3231 fonctionne.

Essaie de le changer d'emplacement sur la breadboard et refais le câblage.

@+

Merci pour vos réponse

J'ai changé de place la RTC sur la breadbord mais c'est toujours pareil
Je viens de testé les connections avec mon multimètre et tout est normal même les soudures un peut "moche" que j'ai fais ne fond pas de défaut .....