Problems uploading sketch using a FTDI USB device

Despite my best efforts, I have been unable to upload any sketches using my FTDI USB device.

The FTDI device I am using happily uploads sketches to any of my Arduino Pro Mini boards, but refuses to do the same with the breadboard UNO, and I cannot figure out why this is.

I have tried setting the FTDI board to either 5V or 3.3V (via onboard jumper)
I have also tried powering the breadboard externally and disconnecting the VCC pin on the FTDI device.
Sadly, none of these things made any difference.

Below are the pinouts I have been using (FTDI Device - Breadboard UNO).

DTR - Reset (pin 1) via 0.1uF capacitor
RX  - TX (pin 3)
TX  - RX (pin 2)
VCC - VCC
CTS - Not connected
GND - GND

When I attempt to upload, the sketch complies and then I see "Uploading", but that's where it stays, until it eventually times out and displays a whole lot of error messages.
Below is a subset of those error messages.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x8d
avrdude: ser_recv(): read error: The I/O operation has been aborted because of either a thread exit or an application request.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x8d
avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: Access is denied.

I should add, I can successfully upload a sketch to the breadboard UNO when using an Arduino UNO with the chip removed as the programmer.

For both setups I have the board set to "Arduino Uno" in the Arduino IDE (v1.8.13)

Are there any different settings that need to be used?

I don't think I have ever seen errors like those.

Well, what can I say... assumptions often make you look like an idiot.

When I said that this FTDI device works fine on an Arduino Pro Mini, that was not exactly true.
My other FTDI device works fine, but the one I have been trying to use on the breadboard Uno, being exactly the same and brand new out of the packaging, obviously has a hardware fault.

After your comment, I decided to try a different FTDI device, and guess what... it worked.
Obviously, the Chinese have a bit more work to do on their QA.

Anyway, the morale of this story is that you should not assume, just because something is new and unused, that it is functional. This this little board definitely proves that. Grrrrrrrrrrrr!

assume ass u me

Yep... I am fully aware of that.
On the plus side, I can now stop tearing my hair out looking for a problem with my PCB setup that never actually existed.

Glad you got it sorted out.
I get my FTDI modules here
https://www.tinyosshop.com/index.php?route=product/product&product_id=600&filter_name=ftdi
and here
https://www.tinyosshop.com/index.php?route=product/product&product_id=186&filter_name=ftdi

They got burned a few years back with the fake FTDIs, got it figured out and have not had a problem since.
I use a lot of them in projects. Currently I have 3 going just in one!

  • Atmega1284P Serial to PC
  • Atmega1284P Serial1 to a Raspberry Pi
  • FIngerprint scanner to a Raspberry Pi

I buy them 10 at a time, mostly the USB-Micro as I seem to have a lot of those cable around.