Programming ATTiny85: compiling error

Hello! I am trying High-Low Tech's tutorial (http://hlt.media.mit.edu/?p=1229) to program ATTiny85 using Arduino Duemilanove. I did everything very carefully and double checked also. When I try to upload a BLINK example, I get compiling error.

In file included from /usr/lib/gcc/avr/4.5.3/../../../avr/include/util/delay.h:44:0, from /usr/lib/gcc/avr/4.5.3/../../../avr/include/avr/delay.h:37, from /home/x/sketchbook/hardware/attiny45_85/cores/attiny45_85/wiring_private.h:32, from /home/x/sketchbook/hardware/attiny45_85/cores/attiny45_85/WInterrupts.c:36: /usr/lib/gcc/avr/4.5.3/../../../avr/include/math.h:426:15: error: expected identifier or ‘(’ before ‘double’ /usr/lib/gcc/avr/4.5.3/../../../avr/include/math.h:426:15: error: expected ‘)’ before ‘>=’ token

What am i doing wrong? BTW - I am using ArduinoISP-dev04b.zip that works with ATMega328P-PU. (using Linux Ubuntu)

Are you using Arduino IDE 0022?

yep, it is Arduino 0022ubuntu0.1

Does this help? http://code.google.com/p/arduino-tiny/issues/detail?id=29

thanks, but commenting out the line (136) in wiring.h: //#define round(x) ((x)>=0?(long)((x)+0.5):(long)((x)-0.5))

causes this: (when trying to program Attiny)

Binary sketch size: 632 bytes (of a 8192 byte maximum) avrdude: stk500_recv(): programmer is not responding

or

Binary sketch size: 632 bytes (of a 8192 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x66

How did you disable auto-reset on the Duemilanove?

wha..what? I don't understand... I haven't disabled anything


Also, what i noticed - when i connect all wires from Duemilanove to ATTiny85 and choose Arduino Duemilanove 328 as board in Arduino software, everything works - i can upload scripts to ATMega328. But when i pick from menu: board ATTiny85 (Arduino as ISP), i get PROGRAMMER NOT RESPONDING / NOT IN SYNC

The following is not directed to you, @D3C3PT1C0N, but to the Arduino folks who continue to leave off the all important step of "disable auto-reset": ARGH! (and a few other expletives not included to keep the board family-friendly plus a long diatribe about adding to the amount of support users need rather than reducing it)

In these instructions...

http://hlt.media.mit.edu/?p=1229

...search for this section...

Connecting the Arduino board and the ATtiny

You are instructed to connect a 10 uF capacitor if you have an Uno. Concluded by this: "The capacitor is only needed if you’re using an Arduino Uno, not an Arduino Duemilanove." Unfortunately, the instructions do not indicate what you will need to do if you are using a Duemilanove. Instead of a capacitor between RESET and GND, you will need to connect a 120 ohm resistor between RESET and 5V. Detailed instructions are here...

http://www.arduino.cc/playground/Main/DisablingAutoResetOnSerialConnection

Thank you, but this also gave me no luck.
I think i’ll go to sleep now. It’s 2 at night here.
Maybe torrow have better ideas …

Good Night!

Still no improvement. I guess that I just leave it there and start developing on ATMega328 chip. Maybe the Tiny controller is just broken.

avrdude: stk500_recv(): programmer is not responding

I also tried the Uno variant - connect a 10 uF capacitor between reset and ground, but no luck again.