Relay Shorted Reason

I am facing one problem with the relay. I connect my water pump and led to the relay which supports 3.3v and 5v. The led is connected to ac to dc converter, then connect to the main power supply. For the water pump connection, there was no something in between. The water pump was smooth, but the led was like it was working for few minutes and after that, the relay used to connect led was shorted. After I switched off the main power supply for led, the relay used to connect with led was not short again. Can anyone tells me the reason and possible solution.
Btw, I connect 3.3v pin to the vcc in the relay. My boss does not want me to use 5v pin.

Once this is moved to the appropriate sub forum, you will be asked to provide a diagram and more details of your hardware.

@lukelouyu1029, your topic has been moved to a more suitable location on the forum. Installation and Troubleshooting is not for problems with your project :wink: See About the Installation & Troubleshooting category.

What does shorted / short mean.

So .. can you please provide a diagram and more details (links to data sheets etc) of your hardware.

ok, i will post it later. Thanks for reminding me.

@johnerrington
This photo shows how I connect the relay.


In actuality, I was planning to do this with the Digilent's Zybo board. Hence, the mainboard I used was not Arduino. But I did try with Arduino as well, I forgot to take photo of my arduino testing.
Here is my schematic:

Here is my code

const int RELAY_PIN = 3;  // the Arduino pin, which connects to the IN pin of relay

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin as an output.
  pinMode(RELAY_PIN, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(RELAY_PIN, LOW);
  delay(15000);
  digitalWrite(RELAY_PIN, HIGH);
  delay(15000);
}

I connect my relay module with the AC to DC converter. The output of the converter has 3 channels. Each channels connect to LED strip. AC side is 240V with 2.1A current. DC side is 12V with 13A current.
Here are pics of AC to DC converter

Problem: The relay works for first one minutes. After that, the relay for the converter and led strip stops function. I used the multimeter to trace and I found out that the relay is shorted. (Like NC becomes NO. NO becomes NC) After one hours, the relay issue automatically solves. I just wonder why?

My first concern is the relay module +Vcc being drawn from the Arduino.

There’s a chance the Arduino on-board 5V regulator is struggling, and may be overheating / shutting down over time.

Is one of the outputs from the AC/DC supply is 5V, or are both fixed 12V ? Some have two separate output voltages.

If you can find a chunky source of 5V, say 500mA - 1A, you might use that to power the relay module…

The relay +v supply (you can even use batteries for testing), should be separate, but the 0V/Gnd must be common with the Arduino 0V so the relay control signal has a common reference between the two boards.

Thanks for you answer. My relay module vcc is tightly connect with Arduino 5V pin. I think the problem is not at Arduino side or Zybo side. The problem is sth to do with the ac to dc power supply for led. I tried the water pump as well and it was working smoothly. The led does not work as successfully as the water pump. The only difference between the water pump connection and led strip connection is there is ac to dc converter "between led strip and relay module". Meanwhile, I tried to connect the arduino with relay module (like how it shown in the schematic) when the cable of the led is not connected with relay module . It was also working well and I can hear the clipping sound.

You said the unit stops after a while…
Let’s find out what stops…

Add a couple of lines to turn the onboard LED (pin 13) on/off in sync with the relay.
Then you can tell if it’s the Arduino or relay module that stops…

Next, you can measure the power supply output voltage while it’s operating properly, and stopped…. you can speed up the cycle time if opit makes testing faster !

Hi, @lukelouyu1029

Thanks for the pics and circuit.
If you remove power to your controller, does the relay open?

If not it looks like the NO contacts have welded closed.

How often do you turn the relay ON and OFF?
You may need a snubber circuit across the COM/NO terminals to reduce arcing at the relay contacts.

A switchmode supply, although rated at 2.1A input, usually has a surge current when switched ON, especially if the load is connected.

What is the make and model of the supply, can you please post a link to where you purchased it and spec/data.

Thanks.. Tom... :smiley: :+1: :coffee: :australia:

This is what relay does when you power it.

1 Like

Thanks for your answer. Regarding to your answer, "You may need a snubber circuit across the COM/NO terminals to reduce arcing at the relay contacts.", do you mean the ac-to-dc converter or the relay module.
I have two times of testing. One testing was let the led to be turned on for 10 minutes. After 10 minutes, I turned off the led and the led still on. Second testing was I controlled the relay in every 20 seconds. Both tests have the problem i just now stated.
The relay module and the ac-to-dc converter was purchased by my supervisors. I needed to clarify with them before posting the spec and data sheet.

Also, normally, if i remove the power, the relay led will be closed and the appliance attached to the relay also closed. When the relay issue arises, the relay les closes but the appliance is in ON state.

The ac to dc converter

The relay module

Break the problem down…
Isolate WHERE the issue occurs.
At the moment you’re shooting blind.

Hi,

Across the COM and NO terminals of the relay.

Yes.
If you do not have the AC/DC power supply disconnected from the relay, does the problem occur?
If not.
If you connect the AC/DC power supply to the relay BUT leave the LEDs disconnected, does the problem occur?

When the problem occurs, does the LED stay on also?

Good idea.

Thanks.. Tom... :smiley: :+1: :coffee: :australia:

Thanks Tom @TomGeorge

I can answer the following question:

If you do not have the AC/DC power supply disconnected from the relay, does the problem occur?
If not.

Yes, my water pump connection can prove that.

If you connect the AC/DC power supply to the relay BUT leave the LEDs disconnected, does the problem occur?

I do not understand what do you mean by "leave the led disconnected". I guess you mean like the main switch of the led is switched off. Yes, I did try on that. When I try to connect the arduino pin with the relay module but the main switch of the led is turned off, it was working. Even though I can't see the outcome from the led side, I can see the relay led status correctly and hear the clipping sound produced by the relay coil.

For actual connection, where arduino pin and LED main switch cable is connected, it was working for first minutes. After 1 minutes, the led dysfunctions. It means when I turned off the led from my side, the led remains on. I connected the led main switch cable in Normally open mode. When I stopped my programming, the led is still turned on and it seems like the relay has turned into NC mode.

Through using the multimeter to check, I found that NC becomes NO and NO becomes NC. I left my relay module aside for about an hour. The relay I was using returned to normal.

And that is all the situation I would like to share

Hi,
The HisayeS-600-12, then the quoted inrush current at 230V is 60A.

Tom.. :smiley: :+1: :coffee: :australia:

here is a major problem.

the relay board takes much more than the on-board voltage regulator.

a separate, power supply of at least 100mA x # of relays AT THE VOLTAGE of the relay is required.

A head engineer I used to work with had a saying
"ignorance gets you in trouble
arrogance keeps you there."

each relay, when energized draws about 80mA
you may be able to get it to work with 1 relay, but you KNOW you have an unstable design.

if you plug your power supply directly into the line voltage, does it work ?
if it works, then the relay is not passing power properly.

if it does not work, the problem is in the power converter.

the answer is binary.