SD card not working

Hello,

I cant get Arduino to recognise SD cards, I use both 1GB Kingston micro SD and 16GB micro SDHC SanDisk Ultra. No success with either. My microSD module looks like that:

Connections: (Module - Nano)
3.3V - 3.3V
CS - 4
MOSI - 11
CLK - 13
MISO - 12
GND - GND

I use CardInfo example and get initialization failed all the time.
I've tried both FAT and FAT32.

Can anyone help me?

Has the card been formatted in the proper manner? Check the sticky in the storage forum.

Yes, I’ve formatted cards “the right way”.

Does Nano have enough power to drive the module off 3.3v? With all those pins, the module can probably run off 5v.

I've tried both 3.3V and 5V.
Also I've tried with Lolin32 Lite board and still no success.
Also I've tried setting pin 10 HIGH, and using pin 10 as CS, nothing.

@EDIT

Just checked soldering and that's OK. Tried powering from STM32F103C8T6 3.3V (and communicating with arduino), nothing, tried powerinf grom Lolin32, nothing.

It might be time to be suss about the card or the module. It appears that setting pin 10 as OUTPUT is no longer needed with the latest IDEs, but I don't know when the change was made. The CS can be pretty well anything, so long as the command matched the wiring. I assume the code is from the IDE Examples, and is truly verbatim.

I have heard from some people that MISO and MOSI have been reverted and that a placechange on those two had solved the problem.

Problem probably solved (??).

I came to my second flat in different city and voila it started working with both Arduino and ESP32. Weird.