Servo Motor Wont Work

Hello, i am trying to make a robotic arm using this youtube tutorial as my guide

i have done everything instructed correctly, but my servo motor’s wont work. I have tried the “sweep” in arduino ide… but it wont work too… it did not respond to any of the codes… i dont know what is the problem can anybody please help and guide me throughout this problem?

  • I have connected the jumper wires gnd to gnd, the wires are also at the correct positions and i have also added external power source…

Can you post photos and a schematic showing your wiring?

What is the external power supply and how is it connected?

What servos?

Post the code that you tried.

Try the Sweep tutorial to go with the Servo->Sweep example:
https://www.arduino.cc/en/Tutorial/LibraryExamples/Sweep

If you follow the tutorial and the servo does not sweep back and forth then something is wrong with the hardware (Servo, Arduino, Wires…)

image0 (1)

i was trying to try making the mg90s micro servo working first then the mg996r work, beforehand i also already try making the mg996r work… but it wont work… but the mg90s micro servo wont work too… if i add an external power supply, the micro servo starts getting hot, i connect it using a jumper wire… i used this code to try get the micro servo running…
#include <Servo.h>
Servo motor;
int p=0;
void setup(){
motor.attach(9);
motor.write(180);
}

void loop (){
for(p=0;p<180;p++)
{
motor.write(p);
delay(10);
}
for(p=180;p>=1;p–)
{
motor.write(p);
delay(10);
}
}

but it wont run at all…

thank youu @johnwasser and @groundFungus i have found the problem… the problem is the hardware… i’ve tried changing to the mg996r and it worked… thank you so muchh all!!!