[solved] An error occured while uploading the sketch

I am new to arduino, recently bought a new board
uno r3
My os is windows 7 32 bit
Arduino ide is 1.6.11
I installed the driver and
I try to upload blink sketch i selected the board as genuino uno and port as com 5 (only that port is there when unplugging its disapearing alsoso confirmed its right one)
When uploading the sketch it loading half. And when it complating showing error
The error i copied it and showing it below please help me


Arduino: 1.6.11 Hourly Build 2016/08/05 06:33 (Windows 7), Board: “Arduino/Genuino Uno”

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
java.io.IOException: Cannot run program “{runtime.tools.avrdude.path}/bin/avrdude”: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:130)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:209)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
at processing.app.Sketch.upload(Sketch.java:1187)
at processing.app.Sketch.exportApplet(Sketch.java:1160)
at processing.app.Sketch.exportApplet(Sketch.java:1132)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2409)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.(ProcessImpl.java:386)
at java.lang.ProcessImpl.start(ProcessImpl.java:137)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
… 9 more
An error occurred while uploading the sketch

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

Please update your Arduino IDE to 1.6.11. When you use the hourly build you have to expect to encounter issues. It's not recommended for beginners, it's only for people who are interested in beta testing to help the Arduino developers. If you do want to use the hourly build then you need to update to the latest hourly build when you have an issue instead of using one that's 3 weeks obsolete since your issue was probably already solved.

I am allredy using 1.6.11

No, you're not. See this:

sherinajumal: Arduino: 1.6.11 Hourly Build 2016/08/05 06:33

That means you're using an hourly build of the beta release of 1.6.11. The official release of 1.6.11 came out on 2016/08/17(see https://www.arduino.cc/en/Main/ReleaseNotes if you don't believe me) and there were some significant changes in the 12 days after the hourly build you're using. Why don't you take a look at how many posts I have and my karma score and the fact that you're here asking for help, assume that I actually know what I'm talking about, and make the effort to actually try the solution I recommended instead of arguing with me about it. Your problem probably would have already been solved by now if you just followed my instructions.

Thank you sir, i did and it worked perfectly and sorry for arguing