[Solved] arduino.exe fails to run (file not found) 1.6.6

trying to upgrade to newer version to check out serial plotter. The start screen comes up with loading configuration then disappears. if i run arduino_debug.exe from an administrator cmd prompt i get the following....

Microsoft Windows Version 6.3.9600 2013 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd C:\Program Files (x86)\Arduino

C:\Program Files (x86)\Arduino>arduino_debug.exe Loading configuration... com.sun.jna.platform.win32.Win32Exception: The system cannot find the file speci fied. at com.sun.jna.platform.win32.Advapi32Util.registryGetStringValue(Advapi 32Util.java:580) at com.sun.jna.platform.win32.Advapi32Util.registryGetStringValue(Advapi 32Util.java:555) at processing.app.windows.Platform.recoverSettingsFolderPath(Platform.ja va:61) at processing.app.windows.Platform.init(Platform.java:56) at processing.app.Base.guardedMain(Base.java:151) at processing.app.Base.main(Base.java:135)

C:\Program Files (x86)\Arduino>

i am running windows 8.1, updated the java and restarted (with the restart option) the computer but no change.

had an issue before with special characters in displayed username its the ' char, but have heard that was fixed. was looking through procmon but did not find anything that caught my eye.

Thanks in advance! ~Kun

github shows the following code for at processing.app.windows.Platform.recoverSettingsFolderPath(Platform.ja va:61)

public void init() throws Exception { super.init();

checkPath(); recoverSettingsFolderPath(); recoverDefaultSketchbookFolder(); }

private void recoverSettingsFolderPath() throws Exception { FolderFinderInWindowsRegistry findInUserShellFolders = new FolderFinderInWindowsRegistry(null, "Documents", "Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders", "Local AppData"); FolderFinderInWindowsRegistry findInShellFolders = new FolderFinderInWindowsRegistry(findInUserShellFolders, "Documents", "Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders", "Local AppData");

Path path = findInShellFolders.find(); this.settingsFolder = path.resolve("Arduino15").toFile(); }

proc mon shows: High Resolution Date & Time: 11/27/2015 3:49:56.6286300 AM Event Class: Registry Operation: RegQueryValue Result: NAME NOT FOUND Path: HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Local AppData TID: 5824 Duration: 0.0000039 Length: 144

which is different (Shell Folders, User Shell Folders) as that only contains one key: !Do not use this registry key:Use the SHGetFolderPath or SHGetKnownFolderPath function instead

i copied over the "Local AppData", "Personal", and "AppData" keys from user shell folders to shell folders and IDE started.

the nightly download did not work either, not sure if others can reproduce this....

Uninstall, delete /user/(your usename)/AppData/Roaming/Arduino15 (note that AppData is a hidden folder), then reinstall.

Debris left behind from 1.5.x versions there breaks new versions of the IDE.

i had renamed that folder but still did not work. fixed issue by copying over registry keys that i documented above. the error makes sense when looking at the code. will file a bug report tomorrow and a patch.