[SOLVED] Arduino Mega won't upload and fails the loopback test.

Hi, my trust Mega2560 just failed on me today :sob: I was playing around with some EDO ram (which I managed to get working actualy :) ) Then, when I wated to upload a new sketch to test the speed of the memory, the arduino IDE compiled the sketch but the upload failed and the IDE crashed (it seemed to be stuck in a loop since one of the cores of my CPU was running at 100%) I tried resetting it and unplugging it and pluging it back in but nothing worked :sob:

Here is the exact error the IDE gives me before crashing (can't get the text, the IDE is completly unresponsive): |500x101

When I do the loopback test, the message comming back is garbled.

Here are a couple of other informations if needed: Arduino Board: Arduino MEGA2560 R3 Windows Version: Windows 10 Enterprise (version 1703) Computer: Asus ROG gl702vm (16Gb ddr4, i7 7700hq (64bit), GTX 1060, asus SSD) IDE Version: ARDUINO 1.8.1 - 2017.01.09

Hope someone can help me fix this board :) I have to say it's quit old, I bought it at least 3 years ago and I have abused it quit a bit.

One more thing: If I need to replace a component of the board, I have experience in soldering/desoldering SMD component, so it shouldn't be an issue.

Thanks :) !

alexandrerouma: I tried resetting it and unplugging it and pluging it back in but nothing worked

It's not clear whether you are talking about the Arduino board or the computer here. Did you try restarting your computer? I've had the serial port get messed up a few times where I just had to restart the computer to get it working again.

I restarted both :/

UPDATE: The board is fixed !!!

I managed to get it working again by copying the bootloader from an other Arduino MEGA and buring it on the broken mega !

Thhanks to everyone who helped !