[Solved] Web editor does not load -- stuck on green loading screen

Tried with:

  • Chrome linux at home (Version 73.0.3683.86 (Official Build) (64-bit)) and at work
  • Chrome OSX at home
  • FireFox linux at home

See attached screenshot for the JS console network tab.

JS console diplays a cors warning and some local connect errors for ports other than (but close to) the Agent Bridge Port

After a while, the tab can’t be closed any longer. Sometimes chrome displays a memory warning

Generally it can be safe to ignore the vendor issues especially if you have clones.

Linux is not my strong point but there are a few posts that may help you along in this section of the forum if you care to read them.

Each OS can have particular quirks.

Reading the posts at the top of this section is highly recommended too.

I'm using Ubuntu Linux 16.04.6 LTS with Firefox 66.0.2 64-bit and am able to reach the Create Editor.

Have you installed the plug-in for your environment? https://github.com/arduino/arduino-create-agent

I doubt the problem is related to the OS as it occurs with MacOS, too.

I have installed the plug-in. Also, I'd expect an error message if the plug-in is not found, as this seems to be easy to miss. Is "hanging" a typical indication of a plug-in issue?

I had searched the forum before filing this bug but was not able to find a similar case.

@haustein

OS is VERY important

No "hanging" is not a "typical" issue at all. Not all MAC OS are supported which is why we ask for the OS so often. It makes it easy to rule out obvious issues.

Quite often on MAC's it can be a permissions issue too.

The devil is in the detail which is why we ask that people read the posts at the top of the forum first. They tell you the types of information that can be very useful to anyone trying to help.

Bob.

There seems to be a rash of similar issues where folks are having an issue getting the Create Website to load.

Searching for the issue, I found an older post that suggested trying to use Incognito mode on your browser.

I am sure that was one of the first things. Just have tried incognito again to be sure (although trying 5 browsers on 3 machines seems to suggest it’s probably not a cookie issue): exactly the same problem, including a “Page Unresponsive” dialog.

Yeah, dude, just trying to help.

I was able to get the Create Editor set-up and access to the Arduino Create IoT Cloud page from a Windows 10 64-bit system without issue using Firefox. From Ubuntu, I can access the sites from either Firefox or Chromium.

There must be something that is being missed with either your account or something that is common with the systems you are using that is preventing access the pages.

For Firefox, this might help, but then again you may have already tried it. https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

Perhaps the folks that support this could provide details of the data they need to help troubleshoot this.

@Jomoengineer

This poster is in another thread (sorta hijacked it) and clearly has not read the rules of the forums at the top of the forum sections. I went through a few things but he didn't seem to want to help such as you and me to help him...

The staff are out until Monday anyway unless its a real emergency for which we have methods to get in touch.

Just a heads up.

Bob.

Hi @haustein, could you please try again? We found the issue, thanks for you report and sorry for the inconvenience!