[SOLVED]Windows 11 Arduino can't upload

Since installing Windows 11 Arduino IDE has not been able to upload to my ESP32 devices or Wemos Di Mini. I checked all the previous post about similar problems to no avail.
I clean installed Version 2.0.0-beta.12 and also the previous stable version but get the same error. I suspect a USB to UART problem but may well be having a senior moment and have forgotten to do something essential. I've tried installing cp201x drivers but that didn't seem to do anything.
Windows only shows one com port: COM1. Windows 10 had several.
This is the error I get:


Any ideas would be most welcome.
Dicky.

Hi @DickyOZ.

Which exact version was that?

You can check whether the port is your Arduino board by doing this:

  1. Unplug your Arduino board from the computer.
  2. Select Tools > Port from the Arduino IDE's menus.
  3. Note the ports, if any, listed in the menu.
  4. Close the Tools menu.
    The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  5. Plug your Arduino board into the computer.
  6. Select Tools > Port from the Arduino IDE's menus. - The new port listed in the menu is the one for your Arduino board.

COM1 is often an internal port on your computer, not related to the Arduino board. But it is possible that it is the Arduino board. The procedure I described above will tell you which it is.

Do your ESP32 and Wemos D1 Mini boards use a CP210x chip? They usually either use that one or the WCH CH340. If the latter, then you will need to install the CH340 drivers.

Thank you for the reply. On windows 10 I had the version 2 Beta and version 1.8.16; both worked without incident. Neither are able to see devices I plug into USB ports on Win 11.

Device manager looks like this:


COM1 is the old serial port.

This is what I see in Arduino:

This is the ESP32 Devkit v1


I have no idea which chip it uses, Cp210 or WCH CH340. Are you able to tell from the photo?

I have installed CP210x 64bit drivers on Win11. But not the CP210x drivers.

It doesn't make any difference to which USB port I plug into, neither Windows or Arduino react to it. In the motherboard (MSI B550M PRO-CDH WiFi AM4) BIOS I have USB XHCI hand off disabled and Legacy set to Auto.
Regards,
Dicky.

Thank you for the clarification. There have been some reports of port recognition problems that are specific to Arduino IDE 2.x, not affecting Arduino IDE 1.8.16. I thought maybe you were having the same problem. Now that I know that the same problem occurs for you with Arduino IDE 1.8.16, and even Windows Device Manager, I know it is not the same.

Yes, thank you. I can see that it is a Silicon Labs CP2102. So the CP210x drivers should be the ones you need.


Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

It's true that the latter is not likely if the board works on Windows 10 with the same cable, but the former can happen at any time.

Once again many thanks for the prompt reply. I was using the USB cable I have used for a couple of years but it has obviously failed. I tried a new cable; as soon as I plugged it into a USB port windows recognised it as COM3. All is now well my sketches upload OK.
I will mark the thread as solved.

1 Like

I'm glad to hear it is working now. Enjoy!
Per