Two issues - Mac unable to find esptools directory - Windows error downloading

Total newbie here. Trying to setup my first arduino using IDE.

First of all I started on my PC. Couldn’t get IDE to run, it would crash at Loading Packages. Tried a few things I found on Google but couldn’t get it working at all.

Moved over to my Mac and got the app loaded, esp board added and created a test sketch using some code I found online. Tried to upload but I’m getting an error.

pyserial or esptool directories not found next to this upload.py

Again on Google, tried a few things but still doesn’t work even though those directories are in the same directory as upload.py.

Hopped back over to my PC and it seems since I tried a fix has come up for the issue I had so now I can load the app. Tried adding the esp board but when I go open board manager I just get two errors

Error downloading http://arduino.esp8266.com/stable/package_esp8266com_index.json
Error downloading https://downloads.arduino.cc/packages/package_index.json

Again, tried looking for some fixes for this but nothing I found works. :frowning:

I followed this guide to get it setup. Wemos D1 Mini Setup | Average Maker

Any help please?

Screenshot_55.png

Just to confirm, the two URLS above I can get to from my browser without an issue. I have also tried temporarily disabling the firewall. Nothing.

Any other ideas?

the windows store "APP" version has caused some issues to users and the full IDE installation package is often the fix for that.

Thanks for using code tags ;D

I was using the downloaded version from the website, for all components including Python.