Unable to COnnect MKR-WIFI 1010

Hi. Im trying to connect my new MKR 1010 for the first time in this IoT Cloud... it said not detecting any board.

Thanks

Pls help ...

The best thing you can do to get assistance with a problem is to help us help you, rather than doing bumps that don't add any useful information and break the forum rules.

Provide a detailed description of what you tried.

Provide the exact and full text of the error message.

Hi Pert,

Thankyou for the reply and thank you for the reminder. My mistake to not give more details information about the problems that i have.

Ok. I just bought a new MKR-Wifi 1010 and trying to connect it with Arduino Create to create new things (this is my first time doing this).

At the first set up step (connecting the board to my laptop vis USB), after i plug the usb to the board: i got an error message: "USB device not recognized" from the laptop and the apps showed "We could not find any board" message. When i connect the usb, the small blue led on the board blinking for several times before it turned off.

Thanks before

The MKR WiFi 1010 ships with the pins stuck into a piece of black anti-static foam. This foam is conductive so you need to remove it before you can use the board.

i've remove it from the anti static foam.

Did that solve the problem?

Hello,

I am having the exact same problem. I would like to add that I am using Windows 10.

I have attached an image of my set up. When I power up the Arduino, there is an orange light that flickers for about a second and then turns off. The green light is permanently on and the yellow light is blinking.

I have installed the local version of the Arduino software and i have also used the Web Based Version. In both cases, the Arduino Board is not being detected.

I also get the same error message when I first connect the Arduino to my Laptop. That is USB device is not recognized.

This is a brand new Arduino.

PS: I am assuming Windows 10 is not the problem.

Thank you,
Hatim

If you've removed the black foam and the problem still occurs, try a different USB cable. I've experienced this problem with low quality USB cables and my MKR WiFi 1010. As soon as I switch to a higher quality cable, it works fine.

Hi Pert,

Nop .. it is not solve the problem. And i also try different usb cables but still windows not detecting the board. Im using windows 10.

Any suggestion?

Hi Again,

I've try to re install Arduino IDE several times but still not success. Every time i connect the board to PC using USB, Windows always gave the same message: "The last USB device you connected to this computer malfunctioned and Windows does not recognize it.".

Can someone help me with this? Its a brand new board.

Hello,

it may be related to power usage: the port (or the cable but as you changed probably is not it's fault) is not providing enough current to the board.

I would suggest trying with a new USB port, maybe even a different cable and at last a different computer.

Is you are connecting the board to the front panel in a desktop pc or a USB hub, try to remove everything and use one USB on the back panel.

Hi,

Thnaks for the hints. Unfortunately i'm using laptop HP Elite X2 with Windows 10 OS. it only have one single USB Port and connected directly to the board. I Have try to change the cable several times also. but still got the same message from the laptop: "The last USB device you connected to this computer malfunctioned and Windows does not recognize it.".

I try to connect to MKR1000 and have no problems. the laptop can recognize it and i can write several sample skecth to it.

Still need help here...

As this seems related to the board an not to the IoT Cloud, to help you get meaningful feedback I'm moving this topic to the MKRWIFI1010 board.

In case the issue persist, you may write to our User Support address: https://www.arduino.cc/en/Main/ContactUs

Hi, I’m working on windows 7 and have the exact same problem. It’s a new board, and my computer won’t detect it. I’ve removed the black foam and everything, and the board is also playing the pre-loaded blink program.
Please respond to me as soon as possible.

I hace the same problem, I have a macOs Catalina, I have tried with two differents cables, and two different computers, and the Arduino Board is not being detected. I already tried to upload a sketch with but the port is not avalible, but if I tried with another type of board like 101 is detected... So I dont know what more I can do.

Hi, I found in the end it was my USB cable. I had an issue connecting to my MKR WIFI 1010 and in the end after I tried every cable in the house I found one that worked.

Yes, in fact my problem was the cable too! Thanks!